Watcher: [illegal_argument_exception] no accounts of type [slack] configured. Please set up an account using the [xpack.notification.slack] settings

alerting

#1

I'm trying to follow: Slack Action | X-Pack for the Elastic Stack [6.1] | Elastic, yet getting following message:

Watcher: [illegal_argument_exception] no accounts of type [slack] configured. Please set up an account using the [xpack.notification.slack] settings

here is my xpack.notification namespace settings:

xpack.notification.slack:
      account:
        monitoring:
          url: https://hooks.slack.com/services/X/Y/Z

Please advise.

P.S. (X/Y/Z in url above, is my own parameters)


(Alexander Reelsen) #2

have you set this in the elasticsearch.yml on all of your nodes in your cluster or just one?


#3

@spinscale I set this across all nodes in cluster - is there a way to check that somehow?


(Alexander Reelsen) #4

did you restart all your nodes? You can run

GET _nodes?filter_path=**.settings.xpack.notification

to check if all your nodes have those settings applied.


#5

Yes, I did restart all nodes, I tried to run your query I've got back nothing(

Is that namespace setting MUST be across all nodes? even ingest and coordinate nodes? or just master and data nodes are fine?


I was however able to address my issue by changing format to a single line, and that seems to work:

xpack.notification.slack.account.monitoring.url=https://hooks.slack.com/services/X/Y/Z

I don't really have elasticsearch.yml as I run elasticsearch via Docker and with Docker there are environment settings that override elasticsearch.yml settings and single line is proper format (I keep forgetting that).


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.