Watcher not starting

alerting

(marc) #1

Hi there,

I'm on a elasticsearch and logstash 2.0 environment.
I installed watcher as it shows in the documentation. I get the plugins installed:

bin/plugin -l

i get this:

Installed plugins:
- watcher
- license

But, when i check the health status:

curl -XGET 'http://localhost:9200/_watcher/stats?pretty'
I get this error:
No handler found for uri [/_watcher/stats?pretty] and method [GET]

Does anywone know why i'm getting this msg? Does it means that it is not well installed?

Thank you


(Alexander Reelsen) #2

Hey,

can you paste the output of curl localhost:9200/_cat/plugins and ``curl localhost:9200/_nodes/plugins`?

Also is watcher installed on all your nodes in your cluster?

--Alex


(marc) #3

Hi spinscale,

the output of the first command is nothing, empty. just carriage return.
the second command's output:

{"cluster_name":"logs","nodes":{"9G5_jCcwTnOTcxtxk2tVOQ":{"name":"Tom Corsi","transport_address":"inet[/192.168.23.102:9300]","host":"servlog","ip":"127.0.1.1","version":"1.3.9","build":"0915c73","http_address":"inet[/192.168.23.102:9200]","plugins":[]}}}

It seems like plugins are not installed, right?


(marc) #4

I don't know if this helps.
I installed the plugin like this:

bin/plugin -i license -u file:/routetolicense.zip

the same for watcher.

If i try with:
bin/plugin install license
i get this error:

-> Installing license...
Trying https://github.com/null/license/archive/master.zip...
Failed to install license, reason: failed to download out of all possible locations..., use --verbose to get detailed information


(Alexander Reelsen) #5

Hey,

your plugin installation command is broken and the command tells you as well that the plugin could not be installed. See the docs to either install plugins when online or use the offline installation

https://www.elastic.co/guide/en/watcher/2.4/installing-watcher.html#offline-installation

--Alex


(marc) #6

Hi Alexander,

I tried all ways to installe it. All seemed not to work, except the one i used.
Finally (as i was checking in a test environament) i reinstalled elk and now it works....not the best solution, but i could not wait anymore.

Thanks


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.