Websocket output broken in 2.2?

I'm getting the error "Errno::EADDRINUSE: Address already in use - bind - Address already in use" when using the websocket output after upgrading from Logstash 2.1 to 2.2. I've also tried it on a clean install of Logstash 2.2.2 with the only additional plugin being logstash-output-websocket, with the same results.

The Logstash config I've been trying to use is:

input {
    stdin {}
filter {}
output {
    websocket {
        port => 32125
        host => ""
        workers => 1

The port is a random one and not being used by anything else - changing it makes no difference to the output. I've set it to 1 worker (tried without it set too) and also tried with -w 1 just in case it was starting multiple workers all trying to bind to the same port, but none of that helped.

I'm guessing this is a bug in Logstash at this point, and I can see there's a bug report about it here which has had no traction for 2 weeks. Where's the best place to take this, or can anyone think of a fix for this problem?