Hi all
I am trying to understand how the eql is difference from the normal search api that we are already using in elastic.
For example
GET /winlogbeat-*/_eql/search
{
"query": """
process where event.type == "start" and
process.parent.name : ("w3wp.exe", "httpd.exe", "nginx.exe", "php.exe", "php-cgi.exe", "tomcat.exe") and
process.name : ("cmd.exe", "cscript.exe", "powershell.exe", "pwsh.exe", "powershell_ise.exe", "wmic.exe", "wscript.exe")
"""
}
and this
GET /winlogbeat-*/_search
{
"query": {
"bool": {
"must": [
{"term": {"process.parent.name": "w3wp.exe"}},
{"term": {"process.name": "cmd.exe"}}
]
}
}
}
Basicaly give the same result so what is exacly is the point of using eql.