When Downloading CSV, one variable value's is getting in two different column because of comma

When Downloading CSV from Tabular format, each variable is getting separated with Comma (,). Due to this variable which are numerical values (for e.g., 2,946) are also getting in different columns.
As shown in below image, Intra_Freq value was 4,678. But due to getting separated with comma, the values are getting split as 4 and 678.

And if go to Advanced setting and format:number:defaultPattern, it will change for all variables. Whereas some of the variables require comma

Please suggest the way forward in this case

Hi @Arshukla

can you share some more information here to reproduce the issue?
What version of the ELK stack are you using?
Is this a CSV coming from a visualization (Lens, Agg-based, etc...) or from a search CSV report (Discover, etc...)?

Hello @Marco_Liberati
I am using v8.6.1 for ES, and Kibana.
the CSV is getting exported from Lens (tabular format)
and when CSV is opened, it applies TEXT TO COLUMN based on Comma (,) as all variables are separated with Comma only. In this process the values which more than hundred, i.e., thousands and have comma in between are getting shifted to next column

But is the CSV exported with the duplicated column and splitted value? Can you open the CSV with a simple text editor and check?

Please find screenshot of the text editor. All values are separated with comma. Even some values which are in thousands are also having Comma in between.

Hi @Arshukla,

Could you please check the current state of "csv:quoteValues" toggle on Advanced Settings page? Switching it on could help in your case.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.