When use curator to manager es 5.4.3 how setting put_mapping time_out


(andy_zhou) #1

when use curator to manager es
i find there is have timeout setting about curator post commad as flow i change the time_out can delete indices:
DELETE http://hostname:9200/system-log-61-2017.08,system-log-61-2017.09,system-log-61-2017.10?master_timeout=300s [status:200 request:4.370s]

this time out can setting about put_mapping timeout the default put_mapping timeout is 30s
but when a large cluster the time is small , how can change the put_mapping default timeout
thanks.
error as
`Preformatted text[2017-10-19T00:01:21,440][DEBUG][o.e.a.a.i.m.p.TransportPutMappingAction] [hostname] failed to put mappings on indic``
s [[[indicesname/xxxxxx]]], type [tepmlate_name]
org.elasticsearch.cluster.metadata.ProcessClusterEventTimeoutException: failed to process cluster
event (put-mapping) within 30s

at org.elasticsearch.cluster.service.ClusterService.lambda$onTimeout$4(ClusterService.java:497) ~[elasticsearch-5.3.0.jar:
5.3.0]
at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingRunnable.run(ThreadContext.java:544) [elasticse
arch-5.3.0.jar:5.3.0]
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:1.8.0_121]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:1.8.0_121]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_121]


(Aaron Mildenstein) #2

There's two different timeouts in play here. One is the client timeout, as defined in your client configuration YAML file, and the other is a master_timeout, which defaults to 30 seconds, but Curator only overrides for the delete_indices action.

The above indicates that the master_timeout has been increased for the delete_indices action. In spite of this increase, the delete indices request has only actually taken 4.37 seconds. Again, the master_timeout change is something Curator does for you, if you are doing the delete_indices action.

failed to process cluster event (put-mapping) within 30s indicates that your cluster cannot process your put mapping request within 30 seconds, regardless of what the client timeout has been set to. I presume you're using something else, as Curator doesn't do mapping requests right now. You may be able to add master_timeout=300s to the end of your request, as that flag works on many different API calls.


(andy_zhou) #3

yes i know about how to add the master_timeout,
bu i don't know how to change the failed to process cluster event (put-mapping) within 30s whe in a large cluster the time is small the put_mapping is use _template auto add when i create index. this seeting is add on the curl put ? i add master_timeout in bulk?


(Aaron Mildenstein) #4

That should be possible, though I've never personally done it. It's the only thing that will help, other than changing the volume of your bulk request to be smaller, or even individual.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.