Where is the error on my mget request?... LoL


(pablo3027) #1

I am tray to do an mget on elasticSearch but this not seems work fine:

My request :

curl -XPOST "http://localhost:9200/index1/tip1/_mget?routing=XXXXX-2-yy"
-d'{"ids": ["2-8","2-26","2-1152"]}'

Response :
{
"docs": [
{
"_index": "custodiafe-indx1",
"_type": "tip1",
"_id": "2-8",
"exists": false
},
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-26",
"exists": false
},
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-1152",
"exists": false
}
]
}

With normal search over index . I can find the elements with this ids

curl -XPOST "http://localhost:9200/indx1/tip1/_search?routing=XXXX-2-yyy"
-d'{ "query": {"match_all": {},"filtered": { "query": {"match_all":
{}},"filter": {"ids": {"values": ["2-8","2-26","2-1152"]}}}}}'

{
"took": 96,
"timed_out": false,
"_shards": {
"total": 1,
"successful": 1,
"failed": 0
},
"hits": {
"total": 2,
"max_score": 1,
"hits": [
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-8",
"_score": 1,
"_source": {
"name" : "aa1"
...
...
},
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-26",
"_score": 1,
"_source": {
"name" : "aa2"
...
...
}
}
]
}
}

Where is the error in the mget request???

Help!!!!!

Thanks

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

can you try to use the _routing fields inside each of the get requests
instead of a global HTTP parameter and see if it works?

--Alex

On Wed, Oct 23, 2013 at 12:33 PM, Pablo Blasco pablo3027@gmail.com wrote:

I am tray to do an mget on elasticSearch but this not seems work fine:

My request :

curl -XPOST "http://localhost:9200/index1/tip1/_mget?routing=XXXXX-2-yy"
-d'{"ids": ["2-8","2-26","2-1152"]}'

Response :
{
"docs": [
{
"_index": "custodiafe-indx1",
"_type": "tip1",
"_id": "2-8",
"exists": false
},
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-26",
"exists": false
},
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-1152",
"exists": false
}
]
}

With normal search over index . I can find the elements with this ids

curl -XPOST "http://localhost:9200/indx1/tip1/_search?routing=XXXX-2-yyy"
-d'{ "query": {"match_all": {},"filtered": { "query": {"match_all":
{}},"filter": {"ids": {"values": ["2-8","2-26","2-1152"]}}}}}'

{
"took": 96,
"timed_out": false,
"_shards": {
"total": 1,
"successful": 1,
"failed": 0
},
"hits": {
"total": 2,
"max_score": 1,
"hits": [
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-8",
"_score": 1,
"_source": {
"name" : "aa1"
...
...
},
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-26",
"_score": 1,
"_source": {
"name" : "aa2"
...
...
}
}
]
}
}

Where is the error in the mget request???

Help!!!!!

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(pablo3027) #3

The same result... grrrr

curl -XPOST "http://localhost:9200/index1/tip1/_mget?http://localhost:9200/index1/tip1/_mget?routing=XXXXX-2-yy
idTip=XXXX&idkind=2&type=yyy

{
"docs": [
{
"_index": "custodiafe-indx1",
"_type": "invoice",
"_id": "2-8",
"exists": false
},
{
"_index": "custodiafe-indx1",
"_type": "invoice",
"_id": "2-26",
"exists": false
},
{
"_index": "custodiafe-indx1",
"_type": "invoice",
"_id": "2-1152",
"exists": false
}
]
}

2013/10/23 Alexander Reelsen alr@spinscale.de

Hey,

can you try to use the _routing fields inside each of the get requests
instead of a global HTTP parameter and see if it works?

--Alex

On Wed, Oct 23, 2013 at 12:33 PM, Pablo Blasco pablo3027@gmail.comwrote:

I am tray to do an mget on elasticSearch but this not seems work fine:

My request :

curl -XPOST "http://localhost:9200/index1/tip1/_mget?routing=XXXXX-2-yy"
-d'{"ids": ["2-8","2-26","2-1152"]}'

Response :
{
"docs": [
{
"_index": "custodiafe-indx1",
"_type": "tip1",
"_id": "2-8",
"exists": false
},
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-26",
"exists": false
},
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-1152",
"exists": false
}
]
}

With normal search over index . I can find the elements with this ids

curl -XPOST "http://localhost:9200/indx1/tip1/_search?routing=XXXX-2-yyy"
-d'{ "query": {"match_all": {},"filtered": { "query": {"match_all":
{}},"filter": {"ids": {"values": ["2-8","2-26","2-1152"]}}}}}'

{
"took": 96,
"timed_out": false,
"_shards": {
"total": 1,
"successful": 1,
"failed": 0
},
"hits": {
"total": 2,
"max_score": 1,
"hits": [
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-8",
"_score": 1,
"_source": {
"name" : "aa1"
...
...
},
{
"_index": "indx1",
"_type": "tip1",
"_id": "2-26",
"_score": 1,
"_source": {
"name" : "aa2"
...
...
}
}
]
}
}

Where is the error in the mget request???

Help!!!!!

Thanks

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/gNVgYC0DGNA/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
Saludos,
Pablo Blasco Martinavarro.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4