Why all replicas are unassigned?

Hello,

I startup 4 nodes on 2 machines, and when create index, all replicas are
unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/bfae28b3-1ef3-4151-bf9e-17fad6d5f16f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

I would check for the Java version on each machine.
I had the same problem on a running cluster when adding a node, and
unfortunately the last node had Java 1.7.0_65 instead of 1.7.0_55
(recommended version and the version of my other machines).

I did not have the time to create a post explaining the whole problem. But,
in summary, I ran a default install script using apt-get and, by default,
they use the "latest" Java version.

One big problem for me is that they do not support versioned jdk
installation and I could not find a deb package for 1.7.0_55. Maybe someone
here can help with this.

The "problematic" command:
apt-get install openjdk-7-jre-headless -y

Regards,
Pablo Musa

On Wednesday, September 10, 2014 10:31:24 PM UTC-3, Sephen Xu wrote:

Hello,

I startup 4 nodes on 2 machines, and when create index, all replicas are
unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/67b8560d-1d41-4005-8f23-32f604b218c8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Thank you for your reply, the java version on each machine are same --
1.6.0_45, and the elasticsearch version is 1.1.2.

在 2014年9月11日星期四UTC+8上午10时48分44秒,pabli...@gmail.com写道:

I would check for the Java version on each machine.
I had the same problem on a running cluster when adding a node, and
unfortunately the last node had Java 1.7.0_65 instead of 1.7.0_55
(recommended version and the version of my other machines).

I did not have the time to create a post explaining the whole problem.
But, in summary, I ran a default install script using apt-get and, by
default, they use the "latest" Java version.

One big problem for me is that they do not support versioned jdk
installation and I could not find a deb package for 1.7.0_55. Maybe someone
here can help with this.

The "problematic" command:
apt-get install openjdk-7-jre-headless -y

Regards,
Pablo Musa

On Wednesday, September 10, 2014 10:31:24 PM UTC-3, Sephen Xu wrote:

Hello,

I startup 4 nodes on 2 machines, and when create index, all replicas are
unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

googled: elasticsearch java 1.6.0_45 shard unassigned

https://github.com/elasticsearch/elasticsearch/issues/3145 (search for 1.6)
https://groups.google.com/forum/#!msg/elasticsearch/MSrKvfgKwy0/Tfk6nhlqYxYJ

For all that I have researched it points to Java version problem.
You could try some things as settings replicas to 0 and putting it back to
1 or forcing allocation (do not remember the exact command, but google for
unassigned chards and you will find it), but I do not think that they will
work.

I really would try installing a new version of Java and running
Elasticsearch using it.

Regards,
Pablo

2014-09-11 0:03 GMT-03:00 Sephen Xu imxuus@gmail.com:

Thank you for your reply, the java version on each machine are same --
1.6.0_45, and the elasticsearch version is 1.1.2.

在 2014年9月11日星期四UTC+8上午10时48分44秒,pabli...@gmail.com写道:

I would check for the Java version on each machine.
I had the same problem on a running cluster when adding a node, and
unfortunately the last node had Java 1.7.0_65 instead of 1.7.0_55
(recommended version and the version of my other machines).

I did not have the time to create a post explaining the whole problem.
But, in summary, I ran a default install script using apt-get and, by
default, they use the "latest" Java version.

One big problem for me is that they do not support versioned jdk
installation and I could not find a deb package for 1.7.0_55. Maybe someone
here can help with this.

The "problematic" command:
apt-get install openjdk-7-jre-headless -y

Regards,
Pablo Musa

On Wednesday, September 10, 2014 10:31:24 PM UTC-3, Sephen Xu wrote:

Hello,

I startup 4 nodes on 2 machines, and when create index, all replicas are
unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAF6PhFJXPbYbXMXPwKSXxdfETpXZO1n4PyBNbsstERgQoSa-XQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hi,Pablo,
I have tried settings replicas to zero and putting it back to 1, it does
not work as you say.

And finally, I found, when I turn
cluster.routing.allocation.same_shard.host: true to false, the replicas was
work well. But on other cluster, this setting does not affect use. And the
official document is to describe this set:
cluster.routing.allocation.same_shard.hostAllows to perform a check to
prevent allocation of multiple instances of the same shard on a single
host, based on host name and host address. Defaults to false, meaning that
no check is performed by default. This setting only applies if multiple
nodes are started on the same machine.
Why is this so?

(Sorry for my bad English : )

在 2014年9月11日星期四UTC+8上午11时12分09秒,Pablo Musa写道:

googled: elasticsearch java 1.6.0_45 shard unassigned

https://github.com/elasticsearch/elasticsearch/issues/3145 (search for
1.6)

https://groups.google.com/forum/#!msg/elasticsearch/MSrKvfgKwy0/Tfk6nhlqYxYJ

For all that I have researched it points to Java version problem.
You could try some things as settings replicas to 0 and putting it back to
1 or forcing allocation (do not remember the exact command, but google for
unassigned chards and you will find it), but I do not think that they will
work.

I really would try installing a new version of Java and running
Elasticsearch using it.

Regards,
Pablo

2014-09-11 0:03 GMT-03:00 Sephen Xu <imx...@gmail.com <javascript:>>:

Thank you for your reply, the java version on each machine are same --
1.6.0_45, and the elasticsearch version is 1.1.2.

在 2014年9月11日星期四UTC+8上午10时48分44秒,pabli...@gmail.com写道:

I would check for the Java version on each machine.
I had the same problem on a running cluster when adding a node, and
unfortunately the last node had Java 1.7.0_65 instead of 1.7.0_55
(recommended version and the version of my other machines).

I did not have the time to create a post explaining the whole problem.
But, in summary, I ran a default install script using apt-get and, by
default, they use the "latest" Java version.

One big problem for me is that they do not support versioned jdk
installation and I could not find a deb package for 1.7.0_55. Maybe someone
here can help with this.

The "problematic" command:
apt-get install openjdk-7-jre-headless -y

Regards,
Pablo Musa

On Wednesday, September 10, 2014 10:31:24 PM UTC-3, Sephen Xu wrote:

Hello,

I startup 4 nodes on 2 machines, and when create index, all replicas
are unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

But on other cluster,

Here you mean cluster or node?

I could not understand, Is everything working as you wanted?

This setting only applies if multiple nodes are started on the same
machine.

Just by curiosity, are you running nodes on the same machine?

Regards,
Pablo

2014-09-11 2:00 GMT-03:00 Sephen Xu imxuus@gmail.com:

Hi,Pablo,
I have tried settings replicas to zero and putting it back to 1, it does
not work as you say.

And finally, I found, when I turn
cluster.routing.allocation.same_shard.host: true to false, the replicas was
work well. But on other cluster, this setting does not affect use. And the
official document is to describe this set:
cluster.routing.allocation.same_shard.hostAllows to perform a check to
prevent allocation of multiple instances of the same shard on a single
host, based on host name and host address. Defaults to false, meaning
that no check is performed by default. This setting only applies if
multiple nodes are started on the same machine.
Why is this so?

(Sorry for my bad English : )

在 2014年9月11日星期四UTC+8上午11时12分09秒,Pablo Musa写道:

googled: elasticsearch java 1.6.0_45 shard unassigned

https://github.com/elasticsearch/elasticsearch/issues/3145 (search for
1.6)
https://groups.google.com/forum/#!msg/elasticsearch/
MSrKvfgKwy0/Tfk6nhlqYxYJ

For all that I have researched it points to Java version problem.
You could try some things as settings replicas to 0 and putting it back
to 1 or forcing allocation (do not remember the exact command, but google
for unassigned chards and you will find it), but I do not think that they
will work.

I really would try installing a new version of Java and running
Elasticsearch using it.

Regards,
Pablo

2014-09-11 0:03 GMT-03:00 Sephen Xu imx...@gmail.com:

Thank you for your reply, the java version on each machine are same --
1.6.0_45, and the elasticsearch version is 1.1.2.

在 2014年9月11日星期四UTC+8上午10时48分44秒,pabli...@gmail.com写道:

I would check for the Java version on each machine.
I had the same problem on a running cluster when adding a node, and
unfortunately the last node had Java 1.7.0_65 instead of 1.7.0_55
(recommended version and the version of my other machines).

I did not have the time to create a post explaining the whole problem.
But, in summary, I ran a default install script using apt-get and, by
default, they use the "latest" Java version.

One big problem for me is that they do not support versioned jdk
installation and I could not find a deb package for 1.7.0_55. Maybe someone
here can help with this.

The "problematic" command:
apt-get install openjdk-7-jre-headless -y

Regards,
Pablo Musa

On Wednesday, September 10, 2014 10:31:24 PM UTC-3, Sephen Xu wrote:

Hello,

I startup 4 nodes on 2 machines, and when create index, all replicas
are unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAF6PhFKef4%2BScgcPdiM0Z3SaQQRvvn-m-gTjycG8gJ%2BTuvB%3Dww%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

uh...'other cluster' is means that another 2 machine build a four node
cluster, and it work fine with cluster.routing.allocation.same_shard.host:
true.

And the problem clusters can work fine
with cluster.routing.allocation.same_shard.host: false.

Now I got the results I wanted, but I fear shards and its replicas will be
assigned to the same machine if I don't
set cluster.routing.allocation.same_shard.host to true.

在 2014年9月11日星期四UTC+8下午1时26分10秒,Pablo Musa写道:

But on other cluster,

Here you mean cluster or node?

I could not understand, Is everything working as you wanted?

This setting only applies if multiple nodes are started on the same
machine.

Just by curiosity, are you running nodes on the same machine?

Regards,
Pablo

2014-09-11 2:00 GMT-03:00 Sephen Xu <imx...@gmail.com <javascript:>>:

Hi,Pablo,
I have tried settings replicas to zero and putting it back to 1, it does
not work as you say.

And finally, I found, when I turn
cluster.routing.allocation.same_shard.host: true to false, the replicas was
work well. But on other cluster, this setting does not affect use. And the
official document is to describe this set:
cluster.routing.allocation.same_shard.hostAllows to perform a check to
prevent allocation of multiple instances of the same shard on a single
host, based on host name and host address. Defaults to false, meaning
that no check is performed by default. This setting only applies if
multiple nodes are started on the same machine.
Why is this so?

(Sorry for my bad English : )

在 2014年9月11日星期四UTC+8上午11时12分09秒,Pablo Musa写道:

googled: elasticsearch java 1.6.0_45 shard unassigned

https://github.com/elasticsearch/elasticsearch/issues/3145 (search for
1.6)
https://groups.google.com/forum/#!msg/elasticsearch/
MSrKvfgKwy0/Tfk6nhlqYxYJ

For all that I have researched it points to Java version problem.
You could try some things as settings replicas to 0 and putting it back
to 1 or forcing allocation (do not remember the exact command, but google
for unassigned chards and you will find it), but I do not think that they
will work.

I really would try installing a new version of Java and running
Elasticsearch using it.

Regards,
Pablo

2014-09-11 0:03 GMT-03:00 Sephen Xu imx...@gmail.com:

Thank you for your reply, the java version on each machine are same --
1.6.0_45, and the elasticsearch version is 1.1.2.

在 2014年9月11日星期四UTC+8上午10时48分44秒,pabli...@gmail.com写道:

I would check for the Java version on each machine.
I had the same problem on a running cluster when adding a node, and
unfortunately the last node had Java 1.7.0_65 instead of 1.7.0_55
(recommended version and the version of my other machines).

I did not have the time to create a post explaining the whole problem.
But, in summary, I ran a default install script using apt-get and, by
default, they use the "latest" Java version.

One big problem for me is that they do not support versioned jdk
installation and I could not find a deb package for 1.7.0_55. Maybe someone
here can help with this.

The "problematic" command:
apt-get install openjdk-7-jre-headless -y

Regards,
Pablo Musa

On Wednesday, September 10, 2014 10:31:24 PM UTC-3, Sephen Xu wrote:

Hello,

I startup 4 nodes on 2 machines, and when create index, all replicas
are unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/daa31c18-a809-40be-a202-53561bdd9ea0%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hi

Did you use some properties of prefix
"cluster.routing.allocation.awareness"?

2014-09-11 14:48 GMT+09:00 Sephen Xu imxuus@gmail.com:

uh...'other cluster' is means that another 2 machine build a four node
cluster, and it work fine with cluster.routing.allocation.same_shard.host:
true.

And the problem clusters can work fine with cluster.routing.allocation.same_shard.host:
false.

Now I got the results I wanted, but I fear shards and its replicas will be
assigned to the same machine if I don't set cluster.routing.allocation.same_shard.host
to true.

在 2014年9月11日星期四UTC+8下午1时26分10秒,Pablo Musa写道:

But on other cluster,

Here you mean cluster or node?

I could not understand, Is everything working as you wanted?

This setting only applies if multiple nodes are started on the same
machine.

Just by curiosity, are you running nodes on the same machine?

Regards,
Pablo

2014-09-11 2:00 GMT-03:00 Sephen Xu imx...@gmail.com:

Hi,Pablo,
I have tried settings replicas to zero and putting it back to 1, it does
not work as you say.

And finally, I found, when I turn cluster.routing.allocation.same_shard.host:
true to false, the replicas was work well. But on other cluster, this
setting does not affect use. And the official document is to describe this
set:
cluster.routing.allocation.same_shard.hostAllows to perform a check to
prevent allocation of multiple instances of the same shard on a single
host, based on host name and host address. Defaults to false, meaning
that no check is performed by default. This setting only applies if
multiple nodes are started on the same machine.
Why is this so?

(Sorry for my bad English : )

在 2014年9月11日星期四UTC+8上午11时12分09秒,Pablo Musa写道:

googled: elasticsearch java 1.6.0_45 shard unassigned

https://github.com/elasticsearch/elasticsearch/issues/3145 (search for
1.6)
https://groups.google.com/forum/#!msg/elasticsearch/MSrKvfgK
wy0/Tfk6nhlqYxYJ

For all that I have researched it points to Java version problem.
You could try some things as settings replicas to 0 and putting it back
to 1 or forcing allocation (do not remember the exact command, but google
for unassigned chards and you will find it), but I do not think that they
will work.

I really would try installing a new version of Java and running
Elasticsearch using it.

Regards,
Pablo

2014-09-11 0:03 GMT-03:00 Sephen Xu imx...@gmail.com:

Thank you for your reply, the java version on each machine are same --
1.6.0_45, and the elasticsearch version is 1.1.2.

在 2014年9月11日星期四UTC+8上午10时48分44秒,pabli...@gmail.com写道:

I would check for the Java version on each machine.
I had the same problem on a running cluster when adding a node, and
unfortunately the last node had Java 1.7.0_65 instead of 1.7.0_55
(recommended version and the version of my other machines).

I did not have the time to create a post explaining the whole
problem. But, in summary, I ran a default install script using apt-get and,
by default, they use the "latest" Java version.

One big problem for me is that they do not support versioned jdk
installation and I could not find a deb package for 1.7.0_55. Maybe someone
here can help with this.

The "problematic" command:
apt-get install openjdk-7-jre-headless -y

Regards,
Pablo Musa

On Wednesday, September 10, 2014 10:31:24 PM UTC-3, Sephen Xu wrote:

Hello,

I startup 4 nodes on 2 machines, and when create index, all replicas
are unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/to
pic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40goo
glegroups.com
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/daa31c18-a809-40be-a202-53561bdd9ea0%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/daa31c18-a809-40be-a202-53561bdd9ea0%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--

Jun Ohtani
blog : http://blog.johtani.info

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAPW8A5waC%3D3kG2GXW7RTPAJ-x-TFBwvMs9iiXxSV2JuxMYJnnA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hi,
Not set .
:slight_smile:

2014-09-11 14:19 GMT+08:00 Jun Ohtani johtani@gmail.com:

Hi

Did you use some properties of prefix
"cluster.routing.allocation.awareness"?

2014-09-11 14:48 GMT+09:00 Sephen Xu imxuus@gmail.com:

uh...'other cluster' is means that another 2 machine build a four node
cluster, and it work fine with cluster.routing.allocation.same_shard.host:
true.

And the problem clusters can work fine with cluster.routing.allocation.same_shard.host:
false.

Now I got the results I wanted, but I fear shards and its replicas will
be assigned to the same machine if I don't set cluster.routing.allocation.same_shard.host
to true.

在 2014年9月11日星期四UTC+8下午1时26分10秒,Pablo Musa写道:

But on other cluster,

Here you mean cluster or node?

I could not understand, Is everything working as you wanted?

This setting only applies if multiple nodes are started on the same
machine.

Just by curiosity, are you running nodes on the same machine?

Regards,
Pablo

2014-09-11 2:00 GMT-03:00 Sephen Xu imx...@gmail.com:

Hi,Pablo,
I have tried settings replicas to zero and putting it back to 1, it
does not work as you say.

And finally, I found, when I turn cluster.routing.allocation.same_shard.host:
true to false, the replicas was work well. But on other cluster, this
setting does not affect use. And the official document is to describe this
set:
cluster.routing.allocation.same_shard.hostAllows to perform a check to
prevent allocation of multiple instances of the same shard on a single
host, based on host name and host address. Defaults to false, meaning
that no check is performed by default. This setting only applies if
multiple nodes are started on the same machine.
Why is this so?

(Sorry for my bad English : )

在 2014年9月11日星期四UTC+8上午11时12分09秒,Pablo Musa写道:

googled: elasticsearch java 1.6.0_45 shard unassigned

https://github.com/elasticsearch/elasticsearch/issues/3145 (search
for 1.6)
https://groups.google.com/forum/#!msg/elasticsearch/MSrKvfgK
wy0/Tfk6nhlqYxYJ

For all that I have researched it points to Java version problem.
You could try some things as settings replicas to 0 and putting it
back to 1 or forcing allocation (do not remember the exact command, but
google for unassigned chards and you will find it), but I do not think that
they will work.

I really would try installing a new version of Java and running
Elasticsearch using it.

Regards,
Pablo

2014-09-11 0:03 GMT-03:00 Sephen Xu imx...@gmail.com:

Thank you for your reply, the java version on each machine are same
-- 1.6.0_45, and the elasticsearch version is 1.1.2.

在 2014年9月11日星期四UTC+8上午10时48分44秒,pabli...@gmail.com写道:

I would check for the Java version on each machine.
I had the same problem on a running cluster when adding a node, and
unfortunately the last node had Java 1.7.0_65 instead of 1.7.0_55
(recommended version and the version of my other machines).

I did not have the time to create a post explaining the whole
problem. But, in summary, I ran a default install script using apt-get and,
by default, they use the "latest" Java version.

One big problem for me is that they do not support versioned jdk
installation and I could not find a deb package for 1.7.0_55. Maybe someone
here can help with this.

The "problematic" command:
apt-get install openjdk-7-jre-headless -y

Regards,
Pablo Musa

On Wednesday, September 10, 2014 10:31:24 PM UTC-3, Sephen Xu wrote:

Hello,

I startup 4 nodes on 2 machines, and when create index, all
replicas are unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/to
pic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40goo
glegroups.com
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/daa31c18-a809-40be-a202-53561bdd9ea0%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/daa31c18-a809-40be-a202-53561bdd9ea0%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--

Jun Ohtani
blog : http://blog.johtani.info

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAPW8A5waC%3D3kG2GXW7RTPAJ-x-TFBwvMs9iiXxSV2JuxMYJnnA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAPW8A5waC%3D3kG2GXW7RTPAJ-x-TFBwvMs9iiXxSV2JuxMYJnnA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CACte%3DQGZNXSAx3tASR-3YjY1gtROkO35Om6acd55J5idVmgeVw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Hi,

Did you find the solution to this. I have the EXACT same issue. 2 Servers
with 4 nodes (2 nodes on each), and only when
"cluster.routing.allocation.same_shard.host: true", all replicas stay
unassigned and no new replica shards get created.

On Friday, 12 September 2014 02:43:29 UTC+1, Sephen Xu wrote:

Hi,
Not set .
:slight_smile:

2014-09-11 14:19 GMT+08:00 Jun Ohtani <joh...@gmail.com <javascript:>>:

Hi

Did you use some properties of prefix
"cluster.routing.allocation.awareness"?

2014-09-11 14:48 GMT+09:00 Sephen Xu <imx...@gmail.com <javascript:>>:

uh...'other cluster' is means that another 2 machine build a four node
cluster, and it work fine with cluster.routing.allocation.same_shard.host:
true.

And the problem clusters can work fine with cluster.routing.allocation.same_shard.host:
false.

Now I got the results I wanted, but I fear shards and its replicas will
be assigned to the same machine if I don't set cluster.routing.allocation.same_shard.host
to true.

在 2014年9月11日星期四UTC+8下午1时26分10秒,Pablo Musa写道:

But on other cluster,

Here you mean cluster or node?

I could not understand, Is everything working as you wanted?

This setting only applies if multiple nodes are started on the same
machine.

Just by curiosity, are you running nodes on the same machine?

Regards,
Pablo

2014-09-11 2:00 GMT-03:00 Sephen Xu imx...@gmail.com:

Hi,Pablo,
I have tried settings replicas to zero and putting it back to 1, it
does not work as you say.

And finally, I found, when I turn cluster.routing.allocation.same_shard.host:
true to false, the replicas was work well. But on other cluster, this
setting does not affect use. And the official document is to describe this
set:
cluster.routing.allocation.same_shard.hostAllows to perform a check
to prevent allocation of multiple instances of the same shard on a single
host, based on host name and host address. Defaults to false, meaning
that no check is performed by default. This setting only applies if
multiple nodes are started on the same machine.
Why is this so?

(Sorry for my bad English : )

在 2014年9月11日星期四UTC+8上午11时12分09秒,Pablo Musa写道:

googled: elasticsearch java 1.6.0_45 shard unassigned

https://github.com/elasticsearch/elasticsearch/issues/3145 (search
for 1.6)
https://groups.google.com/forum/#!msg/elasticsearch/MSrKvfgK
wy0/Tfk6nhlqYxYJ

For all that I have researched it points to Java version problem.
You could try some things as settings replicas to 0 and putting it
back to 1 or forcing allocation (do not remember the exact command, but
google for unassigned chards and you will find it), but I do not think that
they will work.

I really would try installing a new version of Java and running
Elasticsearch using it.

Regards,
Pablo

2014-09-11 0:03 GMT-03:00 Sephen Xu imx...@gmail.com:

Thank you for your reply, the java version on each machine are same
-- 1.6.0_45, and the elasticsearch version is 1.1.2.

在 2014年9月11日星期四UTC+8上午10时48分44秒,pabli...@gmail.com写道:

I would check for the Java version on each machine.
I had the same problem on a running cluster when adding a node, and
unfortunately the last node had Java 1.7.0_65 instead of 1.7.0_55
(recommended version and the version of my other machines).

I did not have the time to create a post explaining the whole
problem. But, in summary, I ran a default install script using apt-get and,
by default, they use the "latest" Java version.

One big problem for me is that they do not support versioned jdk
installation and I could not find a deb package for 1.7.0_55. Maybe someone
here can help with this.

The "problematic" command:
apt-get install openjdk-7-jre-headless -y

Regards,
Pablo Musa

On Wednesday, September 10, 2014 10:31:24 PM UTC-3, Sephen Xu wrote:

Hello,

I startup 4 nodes on 2 machines, and when create index, all
replicas are unassigned.

{
"cluster_name" : "elasticsearch_log",
"status" : "yellow",
"timed_out" : false,
"number_of_nodes" : 4,
"number_of_data_nodes" : 4,
"active_primary_shards" : 22,
"active_shards" : 22,
"relocating_shards" : 0,
"initializing_shards" : 0,
"unassigned_shards" : 22
}

How can I do?

--
You received this message because you are subscribed to a topic in
the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/to
pic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a9
3-4ae8-9b26-8cdd9715eb7b%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/8a7a7fcc-9a93-4ae8-9b26-8cdd9715eb7b%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/
topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/
msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%
40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/f20b0c5a-00c9-42cb-94b7-5ecb59f83904%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/daa31c18-a809-40be-a202-53561bdd9ea0%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/daa31c18-a809-40be-a202-53561bdd9ea0%40googlegroups.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--

Jun Ohtani
blog : http://blog.johtani.info

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/kn3UHQgQKJk/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAPW8A5waC%3D3kG2GXW7RTPAJ-x-TFBwvMs9iiXxSV2JuxMYJnnA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAPW8A5waC%3D3kG2GXW7RTPAJ-x-TFBwvMs9iiXxSV2JuxMYJnnA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/dee8eaed-4877-49e4-9ca6-32e0d85cae4a%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.