Why elasticsearch defined default analyzer doesn't work?


(zhulin) #1

I put content in elasticsearch without define the index setting. It seems
by default elasticsearch isn't using the default analyzer I defined in
elasticsearch.yml.

index.analysis.analyzer.default.type: ik

If I request: http://localhost:9200/useridx/_search?q=Lin

it doesn't using the default analyzer

Could some one help me make the default analyzer ik when querying?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7ab51e8c-cd1c-447e-8f1c-cd17d9f76e38%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2