Why fields can not get doc value filed's content


(赵纯) #1

Hi all

I have a type named 'user', which mapping is following
curl -XGET "localhost:9200/dv_list/user/_mapping?pretty=true"
{
"dv_list" : {
"mappings" : {
"user" : {
"_source" : {
"enabled" : false
},
"properties" : {
"name" : {
"type" : "string",
"index" : "not_analyzed",
"store" : true
},
"point" : {
"type" : "long",
"index" : "no",
"doc_values" : true
}
}
}
}
}
}

when I execute following query,
curl -XPOST 'http://localhost:9200/dv_list/user/_search?pretty=true' -d '{
"query": {
"match_all": {
}
},
"fields": ["point"]
}'

The filed('point')'s content not returned by ES, result is
{
"took" : 3,
"timed_out" : false,
"_shards" : {
"total" : 5,
"successful" : 5,
"failed" : 0
},
"hits" : {
"total" : 7,
"max_score" : 1.0,
"hits" : [ {
"_index" : "dv_list",
"_type" : "user",
"_id" : "5",
"_score" : 1.0
}, {
"_index" : "dv_list",
"_type" : "user",
"_id" : "1",
"_score" : 1.0
}, {
"_index" : "dv_list",
"_type" : "user",
"_id" : "6",
"_score" : 1.0
}, {
"_index" : "dv_list",
"_type" : "user",
"_id" : "4",
"_score" : 1.0
}, {
"_index" : "dv_list",
"_type" : "user",
"_id" : "2",
"_score" : 1.0
}, {
"_index" : "dv_list",
"_type" : "user",
"_id" : "7",
"_score" : 1.0
}, {
"_index" : "dv_list",
"_type" : "user",
"_id" : "3",
"_score" : 1.0
} ]
}
}

If I use "script_fileds", the result can get through "doc['point'].value",
but I think the performace of script_fields is bad than fields'.

My ES version is 1.0.1.

Thanks

Zhao Chun

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f63c3b45-5f71-4d16-ab71-046dde16ae86%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Binh Ly-2) #2

In the mapping, if you set the point field to "store": "yes", you should be
able to get it back.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0bbaf57-7530-4e68-bcee-a0425f9a2986%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(赵纯) #3

Thanks for your reply.

Field has been stored in the format Doc Value, if ES can get Doc Value data with “fields”, the same content only store one time and it is good to the memory which ES used.

在 2014年4月1日,上午5:53,Binh Ly binhly_es@yahoo.com 写道:

In the mapping, if you set the point field to "store": "yes", you should be able to get it back.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/b__n5t_ATCM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d0bbaf57-7530-4e68-bcee-a0425f9a2986%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/5C1319F6-8691-4566-8BA0-259E6047B5B9%40gmail.com.
For more options, visit https://groups.google.com/d/optout.


(赵纯) #4

I solve my problem with "fielddata_fields", and through reading source
code, I guess this performance should be OK

Thanks

在 2014年4月1日星期二UTC+8上午9时52分18秒,Zhao Chun写道:

Thanks for your reply.

Field has been stored in the format Doc Value, if ES can get Doc Value
data with “fields”, the same content only store one time and it is good to
the memory which ES used.

在 2014年4月1日,上午5:53,Binh Ly binhly_es@yahoo.com 写道:

In the mapping, if you set the point field to "store": "yes", you should
be able to get it back.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/b__n5t_ATCM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d0bbaf57-7530-4e68-bcee-a0425f9a2986%40googlegroups.comhttps://groups.google.com/d/msgid/elasticsearch/d0bbaf57-7530-4e68-bcee-a0425f9a2986%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/0e357d8c-a7f7-4040-8940-6c48d591de36%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #5