Why I can see my Colleague's Index?


(Vikas Gopal) #1

Hi Experts,

Me and my Colleague we are working on ELK stack on different machine but on same LAN . We both are using default ELK configurations i.e default yml settings . Now what is happening when I start my node and create some index my colleague can also see my created index and the name of my node has been added to his cluster and data replicates on both the machines . I have 2 questions hare ,why this is happening? ,can we stop this as we are in Dev stage and we both are doing R&D on ELK on 2 different machines ?.

Thanks


(David Pilato) #2

Elasticsearch does multicast by default to discover nodes.
Cluster name is by default elasticsearch. So your nodes probably join and form a cluster.

Change at least the cluster.name.


(Vikas Gopal) #3

Thanks David ,

I like the idea and it works ,Actually I changed the multicast setting to False to stop auto discover .

Thank You


(Sri Harsha Kappala) #4

@vikas_gopal When you install elasticsearch it sets the cluster name to elasticsearch by default. Elasticsearch discover and joins all the nodes with the same cluster name, there by forming a cluster.

By the way if you don't want to this to happen, you can alter this behaviour by changing the cluster.name property in elasticsearch.yml file.


(Vikas Gopal) #5

Thank you sriharshakappala

It works for me.


(Markus Fischer) #6

@vikas_gopal I've researched on the topic for sane local dev-only default settings for ES. It's not specifically targeted for ELK but rather ES, but maybe you will find it useful.

From my /etc/elasticsearch/elasticsearch.yml:

node.local: true
index.number_of_shards: 1
index.number_of_replicas: 0
discovery.zen.ping.multicast.enabled: false

I'm not 100% sure everyone all of them are still accurate as of 1.5/1.6, so I may be corrected on the validity please :smile:

cheers,

  • Markus

(Vikas Gopal) #7

Thank You Markus,

That works for me..cheers!!


(system) #8