Why some boolean settings has two different suffix one is "enable" and another is "enabled"

I want to know why the class EnableAllocationDecider has a setting called cluster.routing.allocation.enable which end with "enable", while class IndicesService has setting indices.id_field_data.enabled which end with "enabled".
Are there any rules for naming these configurations?

That very likely is a design decision from many years ago. Feel free to open a github issue to unify these kind of settings.

OK, I'll do it. Which one do you think is more reasonable? I prefer to “enable”

On top of my head I'd say that enabled is more common, but feel free to leave that to the development team in the GitHub issue.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.