Why was the setting which sent by curl useless?


(kunlin nie) #1

Hi,
I am learning use ES now.Today when i sent request to the ES i get
some problem.
I want create a index named "test".So I followed the demo on the
elasticsearch.org.

$ curl -XPUT 'http://localhost:9200/test/' -d '{
"settings" : {
"index" : {
"number_of_shards" : 3,
"number_of_replicas" : 0
}
}
}'

The index was created successfully.But Why was the setting useless? There were also 5 shards and 1 replicas in the index.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Clinton Gormley) #2

On 25 October 2013 12:21, kunlin nie niekunlin89@gmail.com wrote:

curl -XPUT 'http://localhost:9200/test/' -d '{
"settings" : {
"index" : {
"number_of_shards" : 3,
"number_of_replicas" : 0
}
}
}'

This works correctly for me.

Are you sure the index didn't already exist?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #3