Wildcard and _all with _open don't seem to work in 1.5.2 (solved)


#1

I've just updated my dev machine from 1.4.x to 1.5.2 and can no longer do this:
curl -XPOST 'localhost:9200/someindex*/_open'
curl -XPOST 'localhost:9200/_all/_open'

It always returns IndexMissingException, I've tried setting action.destructive_requires_name to false, but the issue persists. I have many indexes that should match, so has anyone else seen this?


(Mark Walkom) #2

I just tested this using * and _all on 1.5.2 and it worked.

Can you paste something showing a curl call and the output you are seeing?


#3

$ curl -XPOST 'http://localhost:9200/_all/_open'
{"error":"IndexMissingException[[_all] missing]","status":404}

$ curl -XPOST 'http://localhost:9200/iot*/_open'
{"error":"IndexMissingException[[iot*] missing]","status":404}


#4

I'm wondering if I've caused an issue doing a restore off s3 snapshot repo which was half created by 1.4.4 for the first half of the month and continued using 1.5.2 for the second half of the month.


#5

Sorry, I've just worked it out... If there are no closed indexes to open this error is returned.


(Mark Walkom) #6

Well, that was easy then :wink:


(system) #7