Working 2.4 ES stops working when upgraded to 5.0


#1

Oh no, it worked beautifully at 2.4 then crapped out at 5.0. unfortunately, I can't seem to find any good log type indication as to the problem. At the status line I see:

systemctl status elasticsearch

â elasticsearch.service - Elasticsearch
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Thu 2016-10-27 13:47:22 EDT; 5s ago
Docs: http://www.elastic.co
Process: 2665 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG_DIR} -Edefault.path.data=${DATA_DIR} -Edefault.path.conf=${CONF_DIR} (code=exited, status=78)
Process: 2663 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)
Main PID: 2665 (code=exited, status=78)

Oct 27 13:47:16 es-1.eval.org systemd[1]: Starting Elasticsearch...
Oct 27 13:47:16 es-1.eval.org systemd[1]: Started Elasticsearch.
Oct 27 13:47:22 es-1.eval.org systemd[1]: elasticsearch.service: main process exited, code=exited, status=78/n/a
Oct 27 13:47:22 es-1.eval.org systemd[1]: Unit elasticsearch.service entered failed state.
Oct 27 13:47:22 es-1.eval.org systemd[1]: elasticsearch.service failed.


#2

I've narrowed the problem to the "bootstrap.memory_lock: true". When i comment it out , all works now.
I've tried to do the steps as outlined on:
https://www.elastic.co/guide/en/elasticsearch/reference/master/_memory_lock_check.html

but centos 7.x doesnt not seem to support these steps.


(system) #3