Wrong Date

Hi guys.
I run ELK in my environment and I also have filebeat collecting the logs for me. Here in Brazil, we had a special summer time where the clock was advanced by one hour. But this year we won't have that anymore. Today upon entering Kibana, I saw that the log files are at the wrong time, following as if they were in summer time. I have already checked all servers that use Filebeat and saw that they have the correct times. The log files too. Could someone help me with this? I have the impression that i need to change some date parameter or setting from Filebeat or Elasticsearch.

Thanks!

Where in Kibana did you notice this? Also, what is the your configured dateFormat:tz in Kibana -> Advanced Settings?

Hi bro! Thank you for your answer. So.. i did change this but it don't solved.
I tried many differents zones from Brazil but it did not work.
Maybe i have to change some code...

I realized this when i saw on discover screen. after that i did import the Index Patterns.
He is cathing the logs in my server linux with date correct, but inside the kibana appears to me with the date incorrect. And i did check the date in linux servers and it's all right.

Hey Man... i got success! I did choice another TZ from Brazil and it works!
Thank you.

1 Like