Wrong routing of TransportClient with sniffing enabled

Hi

I am using ES 1.1.0 with TransportClient.

We observed wrong routing from TransportClient when we scale up the
cluster. For example, suppose that we have two ES clusters, es0, es1 and
es_sink_0 is the TransportClient talking to es0, es_sink_1 is one talking
to es1. If we scale up es1, it happens that es_sink_0 is sending data to
es1. We are using client.transport.sniff=true by default. This should not
happen theoretically because TransportClient will refresh its server list
through communicating with the cluster and new nodes should not join to the
wrong cluster.

Is there anybody who has seen this problem before? Any comments will be
totally appreciated. We didn't find the root cause yet but this is the
really serious problem. So, temporarily, I want to turn off sniff and add
the feature that manually updates the server list through external discover
module.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/7a34e016-b322-48aa-a1de-a43249e7b58d%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

You must set

client.transport.ignore_cluster_name

to "false", see

http://www.elasticsearch.org/guide/en/elasticsearch/client/java-api/current/client.html

Jörg

On Fri, Dec 19, 2014 at 8:09 AM, Jae metacret@gmail.com wrote:

Hi

I am using ES 1.1.0 with TransportClient.

We observed wrong routing from TransportClient when we scale up the
cluster. For example, suppose that we have two ES clusters, es0, es1 and
es_sink_0 is the TransportClient talking to es0, es_sink_1 is one talking
to es1. If we scale up es1, it happens that es_sink_0 is sending data to
es1. We are using client.transport.sniff=true by default. This should not
happen theoretically because TransportClient will refresh its server list
through communicating with the cluster and new nodes should not join to the
wrong cluster.

Is there anybody who has seen this problem before? Any comments will be
totally appreciated. We didn't find the root cause yet but this is the
really serious problem. So, temporarily, I want to turn off sniff and add
the feature that manually updates the server list through external discover
module.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7a34e016-b322-48aa-a1de-a43249e7b58d%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a34e016-b322-48aa-a1de-a43249e7b58d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKdsXoH2eMmpbvo%2Bvymyg6Y5XxxYTd_dABZ2VkmNJfa-bVKXNA%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

I already did because it's default right? Also, I am seeing the following
which is the proof of not ignoring cluster name.

2014-12-19 06:58:08,187 WARN elasticsearch[Sun Girl][generic][T#49358]
transport - [Sun Girl] node null not part of the cluster Cluster
[es_logsummary], ignoring...

On Fri, Dec 19, 2014 at 1:56 AM, joergprante@gmail.com <
joergprante@gmail.com> wrote:

You must set

client.transport.ignore_cluster_name

to "false", see

http://www.elasticsearch.org/guide/en/elasticsearch/client/java-api/current/client.html

Jörg

On Fri, Dec 19, 2014 at 8:09 AM, Jae metacret@gmail.com wrote:

Hi

I am using ES 1.1.0 with TransportClient.

We observed wrong routing from TransportClient when we scale up the
cluster. For example, suppose that we have two ES clusters, es0, es1 and
es_sink_0 is the TransportClient talking to es0, es_sink_1 is one talking
to es1. If we scale up es1, it happens that es_sink_0 is sending data to
es1. We are using client.transport.sniff=true by default. This should not
happen theoretically because TransportClient will refresh its server list
through communicating with the cluster and new nodes should not join to the
wrong cluster.

Is there anybody who has seen this problem before? Any comments will be
totally appreciated. We didn't find the root cause yet but this is the
really serious problem. So, temporarily, I want to turn off sniff and add
the feature that manually updates the server list through external discover
module.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/7a34e016-b322-48aa-a1de-a43249e7b58d%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/7a34e016-b322-48aa-a1de-a43249e7b58d%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoH2eMmpbvo%2Bvymyg6Y5XxxYTd_dABZ2VkmNJfa-bVKXNA%40mail.gmail.com
https://groups.google.com/d/msgid/elasticsearch/CAKdsXoH2eMmpbvo%2Bvymyg6Y5XxxYTd_dABZ2VkmNJfa-bVKXNA%40mail.gmail.com?utm_medium=email&utm_source=footer
.

For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAKe7ALc%2BCFz9wA4ha_MK%2BAMMvAv9dJM%2BBPdHExU%2B%3Dq%2BgQoa-cw%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.