Wrong url in uptime UI for ERR_CERT_AUTHORITY_INVALID


I am testing the synthetics package in version 7.12:
I have a simple journey that looks like this:

- type: browser
  id: pdl-ui-test
  name: pdl-ui-test
  schedule: "@every 1m"
      script: |- 
        step("Open application", async () => {
          await page.goto('https://myhost.mycompany.com:8443/myapp/');

Because the application uses a company cert with our companies root CA chromium rejects the certificate. This is expected as the synthetics package does not yet support custom certs.

But, I would expect to see the Uptime UI to show the correct url, but all I see is:

Note that the Url is shown as about:blank instead of https://myhost.mycompany.com:8443/myapp/. Only in the monitor details I see the real url in the error message.

Is there a possibility to show the correct url in uptime?

Please note that I am NOT using the docker version - I have installed heartbeat, synthetics and co. manually.

Best regards

Interesting find @Wolfram_Haussig . This is sort of a tricky situation. The URL is calculated by looking at the browser location at the end of the stop. However, the browser never reaches that location due to the cert issue. This is probably a unique situation that only arises on TLS failures, but is something we'd like to fix. @vigneshshanmugam any thoughts here on this?

WRT the CA issues, we have an open issue for that here: Support custom cert store · Issue #170 · elastic/synthetics · GitHub . Our goal would be to make the experience less cumbersome than it normally is in playwright.

That said I think Chromium should still be able to use the system certificate store if the cert is installed there. Have you tried installing the cert system-wide?

The about:blank is actually a bug as mentioned by Andrew, I have created an issue in our Synthetics agent to handle navigation failures - [bug] url points to `about:blank` on initial navigation failure · Issue #255 · elastic/synthetics · GitHub


Hello Andrew,

Thank you for your response! I have not tried to install the certificate into the system store as those servers are managed by a provider and we are not allowed to change the system. I will try to get the certificate into the store and report back.

Best regards

Hello @Andrew_Cholakian1 ,

I got our root certificate installed and it works like a charm now! I am still looking forward to the custom cert support so we do not have to modify the system but I can play around now :tada:

Best regards

This topic was automatically closed 24 days after the last reply. New replies are no longer allowed.