X-pack default password is not working for Elasticsearch 5.6.8 version


(Bob) #1

Hi,
I installed X-Pack(5.6.8) plugin on ElasticSearch(5.6.8).Here is the error I see when I try to do curl with default password.

[root@dev01-2 elasticsearch]# curl -XGET -u elastic:changeme http://10.2.2.5:9200
{"error":{"root_cause":[{"type":"security_exception","reason":"failed to authenticate user [elastic]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}}],"type":"security_exception","reason":"failed to authenticate user [elastic]","header":{"WWW-Authenticate":"Basic realm="security" charset="UTF-8""}},"status":401}[root@dev01-2 elasticsearch]#

Please help me to resolve the issue?


(Ry Biesemeyer) #2

Is the default password enabled, or has it been changed to something else? Has Elasticsearch been restarted since installing x-pack?

https://www.elastic.co/guide/en/x-pack/5.6/setting-up-authentication.html#disabling-default-password


(Bob) #3

Thanks.

After adding below setting to elasticsearch.yml, it is working fine.

xpack.security.enabled: true
xpack.graph.enabled: true
xpack.ml.enabled: true
xpack.monitoring.enabled: true
xpack.watcher.enabled: true
xpack.security.authc.accept_default_password: true


(Bob) #4

Hi,
Somehow after adding new node to elasticsearch cluster, default password not working again.Can you please help me to fix the issue?

Both nodes have same configuration.


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.