X-Pack was Installed for ES and Kibana


(levi) #1

Dear team,
I flow the X-Pack 's install url
https://www.elastic.co/guide/en/x-pack/5.0/installing-xpack.html#xpack-installing-offline

   when I start the Es, it's throw an java UnsupportedOperationException, at the end of Es is running.as fallows:

[hadoop@elk-test-6 elasticsearch-5.0.1]$ bin/elasticsearch
[2016-11-17T09:06:37,196][WARN ][o.e.b.JNANatives ] unable to install syscall filter:
java.lang.UnsupportedOperationException: seccomp unavailable: CONFIG_SECCOMP not compiled into kernel, CONFIG_SECCOMP and CONFIG_SECCOMP_FILTER are needed
[2016-11-17T08:57:15,122][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [reindex]
[2016-11-17T08:57:15,122][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [transport-netty3]
[2016-11-17T08:57:15,122][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [transport-netty4]
[2016-11-17T08:57:15,124][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded plugin [x-pack]
[2016-11-17T08:57:17,918][INFO ][o.e.n.Node ] [3_RSmmb] initialized
[2016-11-17T08:57:17,918][INFO ][o.e.n.Node ] [3_RSmmb] starting ...
[2016-11-17T08:57:18,852][INFO ][o.e.t.TransportService ] [3_RSmmb] publish_address {127.0.0.1:9300}, bound_addresses {[::1]:9300}, {127.0.0.1:9300}
[2016-11-17T08:57:18,858][WARN ][o.e.b.BootstrapCheck ] [3_RSmmb] max file descriptors [8192] for elasticsearch process is too low, increase to at least [65536]
[2016-11-17T08:57:18,858][WARN ][o.e.b.BootstrapCheck ] [3_RSmmb] max number of threads [1024] for user [hadoop] is too low, increase to at least [2048]
[2016-11-17T08:57:18,858][WARN ][o.e.b.BootstrapCheck ] [3_RSmmb] max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
[2016-11-17T08:57:21,952][INFO ][o.e.c.s.ClusterService ] [3_RSmmb] new_master {3_RSmmb}{3_RSmmbbSPakUsC6VwHyzg}{x0StCQTpQDS4VtJelZcpkA}{127.0.0.1}{127.0.0.1:9300}, reason: zen-disco-elected-as-master ([0] nodes joined)
[2016-11-17T08:57:22,085][INFO ][o.e.h.HttpServer ] [3_RSmmb] publish_address {127.0.0.1:9200}, bound_addresses {[::1]:9200}, {127.0.0.1:9200}
[2016-11-17T08:57:22,085][INFO ][o.e.n.Node ] [3_RSmmb] started
[2016-11-17T08:57:22,800][INFO ][o.e.g.GatewayService ] [3_RSmmb] recovered [6] indices into cluster_state
[2016-11-17T08:57:23,677][INFO ][o.e.c.r.a.AllocationService] [3_RSmmb] Cluster health status changed from [RED] to [YELLOW] (reason: [shards started [[.monitoring-es-2-2016.11.16][0], [.monitoring-data-2][0]] ...]).

the kibana was started status as fallows:

log [01:07:23.899] [info][status][plugin:kibana@5.0.1] Status changed from uninitialized to green - Ready
log [01:07:23.967] [info][status][plugin:elasticsearch@5.0.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [01:07:23.991] [info][status][plugin:xpack_main@5.0.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [01:07:24.184] [info][status][plugin:graph@5.0.1] Status changed from uninitialized to yellow - Waiting for Elasticsearch
log [01:07:24.189] [info][status][plugin:elasticsearch@5.0.1] Status changed from yellow to green - Kibana index ready
log [01:07:24.206] [info][license][xpack] Imported license information from Elasticsearch: mode: trial | status: active | expiry date: 2016-12-16T17:52:09+08:00
log [01:07:24.228] [info][status][plugin:monitoring@5.0.1] Status changed from uninitialized to yellow - Waiting for Monitoring Health Check
log [01:07:24.230] [info][status][plugin:xpack_main@5.0.1] Status changed from yellow to green - Ready
log [01:07:24.231] [info][status][plugin:graph@5.0.1] Status changed from yellow to green - Ready
log [01:07:24.242] [warning][reporting] Generating a random key for xpack.reporting.encryptionKey. To prevent pending reports from failing on restart, please set xpack.reporting.encryptionKey in kibana.yml
log [01:07:24.245] [info][status][plugin:reporting@5.0.1] Status changed from uninitialized to green - Ready
log [01:07:26.053] [info][status][plugin:console@5.0.1] Status changed from uninitialized to green - Ready
log [01:07:26.062] [info][status][plugin:monitoring@5.0.1] Status changed from yellow to green - Ready
log [01:07:26.233] [info][status][plugin:timelion@5.0.1] Status changed from uninitialized to green - Ready
log [01:07:26.238] [info][listening] Server running at http://localhost:5601
log [01:07:26.239] [info][status][ui settings] Status changed from uninitialized to green - Ready

BTW, I Set the

xpack.security.enabled: false
action.auto_create_index: .security,.monitoring*,.watches,.triggered_watches,.watcher-history*
in each of elasticsearch.yml and kibana.yml file

But I Cannot visit the kibana UI, any help?

Levi,
Thanks!


(Christian Dahlqvist) #2

Elasticsearch 5.0 added a number of bootstrap checks that need to be passed, and your Elasticsearch is complaining about these and therefore not starting up. This blog post also provides some additional background on the introduction of these checks.


(levi) #3

hi Dahlqvist,
I set the values in the limits.conf
hadoop hard nofile 262144
hadoop hard nproc 2048
hadoop hard as unlimited
hadoop soft nofile 262144
hadoop soft nproc 2048
hadoop soft as unlimited

when I restart es, the other WARN were resolved, Just the max virtual memory areas is not work. any help?

[2016-11-17T16:04:28,064][INFO ][o.e.n.Node ] [3_RSmmb] initialized
[2016-11-17T16:04:28,064][INFO ][o.e.n.Node ] [3_RSmmb] starting ...
[2016-11-17T16:04:29,070][INFO ][o.e.t.TransportService ] [3_RSmmb] publish_address {127.0.0.1:9300}, bound_addresses {[::1]:9300}, {127.0.0.1:9300}
[2016-11-17T16:04:29,077][WARN ][o.e.b.BootstrapCheck ] [3_RSmmb] max virtual memory areas vm.max_map_count [65530] is too low, increase to at least [262144]
[2016-11-17T16:04:32,155][INFO ][o.e.c.s.ClusterService ] [3_RSmmb] new_master {3_RSmmb}{3_RSmmbbSPakUsC6VwHyzg}{LGqXPMjFSF64UoEf7EjB6Q}{127.0.0.1}{127.0.0.1:9300}, reason: zen-disco-elected-as-master ([0] nodes joined)
[2016-11-17T16:04:32,209][INFO ][o.e.h.HttpServer ] [3_RSmmb] publish_address {127.0.0.1:9200}, bound_addresses {[::1]:9200}, {127.0.0.1:9200}
[2016-11-17T16:04:32,209][INFO ][o.e.n.Node ] [3_RSmmb] started
[2016-11-17T16:04:32,947][INFO ][o.e.g.GatewayService ] [3_RSmmb] recovered [6] indices into cluster_state
[2016-11-17T16:04:34,208][INFO ][o.e.c.r.a.AllocationService] [3_RSmmb] Cluster health status changed from [RED] to [YELLOW] (reason: [shards started [[.monitoring-es-2-2016.11.16][0], [.monitoring-data-2][0]] ...]).

thanks
Levi


(Christian Dahlqvist) #4

Did this part of the documentation not work?


(levi) #5

hi Dahlqvist,
thanks for suggestion! All the WARN INFO was resolved! I cannot visit the Kibana site and check the 5601 is opening ...

netstat -anp | grep 5601
tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN 2197/bin/../node/bi

any help?


(Christian Dahlqvist) #6

Elasticsearch 5.0 by default binds to localhost.

Is you Kibana instance on the same host as Elasticsearch? Is Elasticsearch up and running?


(levi) #7

yes ,there are on the same host, the Elasticsearch is running:

[3278], build[080bb47/2016-11-11T22:08:49.812Z], OS[Linux/2.6.32-642.el6.x86_64/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0_73/25.73-b02]
[2016-11-17T17:14:33,855][WARN ][o.e.x.XPackPlugin ] the [action.auto_create_index] setting is configured to be restrictive [.security,.monitoring*,.watches,.triggered_watches,.watcher-history*]. for the next 6 months daily history indices are allowed to be created, but please make sure that any future history indices after 6 months with the pattern [.watcher-history-YYYY.MM.dd] are allowed to be created
[2016-11-17T17:14:33,870][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [aggs-matrix-stats]
[2016-11-17T17:14:33,870][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [ingest-common]
[2016-11-17T17:14:33,871][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [lang-expression]
[2016-11-17T17:14:33,871][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [lang-groovy]
[2016-11-17T17:14:33,871][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [lang-mustache]
[2016-11-17T17:14:33,871][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [lang-painless]
[2016-11-17T17:14:33,872][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [percolator]
[2016-11-17T17:14:33,872][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [reindex]
[2016-11-17T17:14:33,872][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [transport-netty3]
[2016-11-17T17:14:33,872][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded module [transport-netty4]
[2016-11-17T17:14:33,874][INFO ][o.e.p.PluginsService ] [3_RSmmb] loaded plugin [x-pack]
[2016-11-17T17:14:36,734][INFO ][o.e.n.Node ] [3_RSmmb] initialized
[2016-11-17T17:14:36,734][INFO ][o.e.n.Node ] [3_RSmmb] starting ...
[2016-11-17T17:14:37,726][INFO ][o.e.t.TransportService ] [3_RSmmb] publish_address {127.0.0.1:9300}, bound_addresses {[::1]:9300}, {127.0.0.1:9300}
[2016-11-17T17:14:40,836][INFO ][o.e.c.s.ClusterService ] [3_RSmmb] new_master {3_RSmmb}{3_RSmmbbSPakUsC6VwHyzg}{GaHW_TVETNuUa_oy8tp-jw}{127.0.0.1}{127.0.0.1:9300}, reason: zen-disco-elected-as-master ([0] nodes joined)
[2016-11-17T17:14:40,891][INFO ][o.e.h.HttpServer ] [3_RSmmb] publish_address {127.0.0.1:9200}, bound_addresses {[::1]:9200}, {127.0.0.1:9200}
[2016-11-17T17:14:40,892][INFO ][o.e.n.Node ] [3_RSmmb] started
[2016-11-17T17:14:41,747][INFO ][o.e.g.GatewayService ] [3_RSmmb] recovered [6] indices into cluster_state
[2016-11-17T17:14:42,725][INFO ][o.e.c.r.a.AllocationService] [3_RSmmb] Cluster health status changed from [RED] to [YELLOW] (reason: [shards started [[.monitoring-es-2-2016.11.16][0], [.monitoring-data-2][0]] ...]).


(levi) #8

thanks for suggestion! it's worked!


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.