Xgo not found when running the make step in a beat-generator generated beat


(David Reagan) #1

After making a test beat with beat-generator, I tried building it with the dev-tools/packer scripts.

The readme has this section:

Package

To cross-compile and package Davidbeat for all supported platforms, run the following commands:

cd dev-tools/packer
make deps
make images
make

I successfully ran the first three commands. (Though make images had to be run a few times when my system couldn't connect to archive.debian.org for a while...) But when I run make, it throws an error.

$GOPATH/path/to/packer: make
mkdir -p build/upload
# cross compile on ubuntu
cd build && xgo -image=tudorg/beats-builder \
        -before-build=../../../vendor/github.com/elastic/beats/dev-tools/packer/xgo-scripts/before_build.sh \
        -pkg davidbeat \
        -source ../../.. \
        github.com/jerrac/davidbeat
/bin/sh: 1: xgo: not found
make: *** [davidbeat] Error 127

Did make deps not install xgo? Was it supposed to? Or was I supposed to manually install?

I'm running LinuxMint 17.2. Which is basically the same as Ubuntu 14.04 from what I can tell. 64bit.

Tag @ruflin since he said to contact him if I had issues. :slight_smile:


(ruflin) #2

Thanks for pinging me here. It looks like this is probably missing. The xgo version we are using can be found here: https://github.com/tsg/xgo

Can you add this to the issue here (https://github.com/elastic/beat-generator/issues/29) or create a new one? We should definitively automatically install this.


(David Reagan) #3

Done. :slight_smile: https://github.com/elastic/beat-generator/issues/30


(ruflin) #4

Thanks


(system) #5