-XX:OnOutOfMemoryError not working if Elasticsearch starts with -d paramater


I am trying to execute a file when OutOfMemoryError occurs with -XX:OnOutOfMemoryError= option in jvm.options file.

If I am starting elasticsearch without "-d" parameter from command line(elasticsearch) then it is woking and calling the file.

But with the "-d" paramater from command line(elasticsearch -d) it is not working when ES is going out of memory.

P.S: I have disable the system_call_filter bootstrap.system_call_filter: false

ES version: 5.6.4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.