Yarn build fails

Hello there,

I am trying to build archive for my custom plugin. I am following the process in the link below.

So, I generated the plugin with the generate_plugin script but then it says that in order to use my plugin in production, I need to run yarn build to generate the archive of my plugin.

but it gives me following errors.

$ yarn build
yarn run v1.21.1
$ node scripts/build --all-platforms
 info [  global  ] Verifying environment meets requirements
   β”‚ succ Node.js version verified
   β”‚ succ βœ“ 0 sec

 info [  global  ] Cleaning artifacts from previous builds
   β”‚ debg Deleting patterns: [
   β”‚        'C:\\TEMP\\ELK-Development\\kibana\\build',
   β”‚        'C:\\TEMP\\ELK-Development\\kibana\\target',
   β”‚        'C:\\TEMP\\ELK-Development\\kibana\\.node_binaries'
   β”‚      ]
   β”‚ debg Deleted 1 files/directories
   β”‚ succ βœ“ 0 sec

 info [  global  ] Downloading node.js builds for all platforms
   β”‚ debg Downloading shasum values for node version 14.17.2 from https://us-central1-elastic-kibana-184716.cloudfunctions.net/kibana-ci-proxy-cache/dist/v14.17.2/SHASUMS256.txt
   β”‚ERROR failure 0 sec
   β”‚ERROR Error: getaddrinfo ENOTFOUND us-central1-elastic-kibana-184716.cloudfunctions.net
   β”‚          at GetAddrInfoReqWrap.onlookup [as oncomplete] (dns.js:69:26)

error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

Has anyone seen this error before?

Thank you!

Hi Akhil,

The ENOTFOUND error means that Node wasn't able to connect to the URL for the shasum text file from your computer. It's possible the server was down momentarily, or you were possibly having some connection issues at the time. Are you able to access the following URL in a browser?


If so, you may want to try again and see if it works now. I'm able to load this URL on my end.

If not, there may be something in your network settings preventing you from accessing this file.

Hope this helps!

Hello @GavinAnderegg ,

Thanks for replying. I appreciate your help. I tried to access the URL in a browser.
Is this the right content on this URL? Just confirming.

I am behind corporate proxy and added some settings for yarn, node and Gitbash to bypass proxy.

Thank you,

Hi @Akhil2,

Yes, that is the same content I see when I visit the URL.

Thanks @GavinAnderegg. I am trying everything. I reset those yarn, npm and GitHub configs to bypass proxy again but same errors are coming up.

Hi @Akhil2, sadly I'm not sure what else to try. The issue is likely in Bazel, the build system Kibana uses. It's possible this StackOverflow answer might help?

I'm currently having a lot of issues coming to grips with Bazel and the rest of the toolchain for plugin development, so you're definitely not alone here.

Thanks @GavinAnderegg for the guidance! I will definitely look into Stack Overflow answers.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.