_mlt ignoring the fields argument?


(didier deshommes) #1

Hi,
I've issued a mlt query like this:

curl -XGET 'http://localhost:9200/examinercogtree/article/4c59cc3cdbe1afb1d8004fb4/_mlt?fields=article_content&pmin_word_len=3&pretty=true'
-d ' {"size":"1", "explain":"1" } '

In my config, article_content has term_vectors set to yes. When
looking at the explain output from the mlt query, I notice that the
terms used to generate the query are not solely from the
article_content field, they are also from another field (which
doesn't have term vectors enabled). Does this mean that _mlt is not
respecting the fields argument? Also, Is there a way to ensure that
mlt queries will fail on fields that don't have term vectors enabled?
I understand that mlt is faster if your field has term vectors
enabled.

didier


(system) #2