_timestamp and multifield mapping failed


(Jason Wee) #1

Hello,

using elasticsearch version 1.5.2 and index was created with ttl enable and
_timestamp store as of following:

curl -XGET 'http://localhost:9200/_mappings?pretty'
{
"myindex" : {
"mappings" : {
"mytype1" : {
"_timestamp" : {
"enabled" : true,
"store" : true
},
"_ttl" : {
"enabled" : true
},
"properties" : { }
},
"mytype2" : {
"_timestamp" : {
"enabled" : true,
"store" : true
},
"_ttl" : {
"enabled" : true
},
"properties" : { }
}
}
}
}

however, when a "multi field" to type mytype1

curl -s -XPUT 'localhost:9200/myindex/mytype1/_mapping' -d '
{
"mytype1" : {
"properties": {
"mytype1_sub" : {
"type": "string",
"index" : "analyzed",
"fields" : {
"untouched" : { "type": "string", "index" : "not_analyzed" }
}
}
}
}
}'

{"error":"MergeMappingException[Merge failed with failures {[mapper
[_timestamp] has different store values]}]","status":400}

What went wrong? The index created without _timestamp, it works for the
multi field, can anyone explain?

Jason

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1ebe362a-65eb-4e8d-a89d-8116e49be0dc%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(system) #2