0.19.1 Upgrade issue


(Chris.Rode) #1

Hey guys

Last week we upgraded our staging servers from 0.18.7 to ES 0.19.1 and
are trying to do the same with our production servers now. We had an
intermittent problem in staging that cleared up and went away. However
that same error is now plaguing us in production

{0.19.1}: Initialization Failed ...

  1. NoClassDefFoundError[org/elasticsearch/common/util/concurrent/
    DynamicExecutors]

ClassNotFoundException[org.elasticsearch.common.util.concurrent.DynamicExecutors]2)
NoClassDefFoundError[org/elasticsearch/common/util/concurrent/
DynamicExecutors]

Any ideas?


(Shay Banon) #2

Check if you didn't install 0.19 "on" 0.18, also, if you have plugins, make
sure the version you use for them is compatible with 0.19.

On Thu, Apr 12, 2012 at 7:04 AM, Chris Rode cirode@gmail.com wrote:

Hey guys

Last week we upgraded our staging servers from 0.18.7 to ES 0.19.1 and
are trying to do the same with our production servers now. We had an
intermittent problem in staging that cleared up and went away. However
that same error is now plaguing us in production

{0.19.1}: Initialization Failed ...

  1. NoClassDefFoundError[org/elasticsearch/common/util/concurrent/
    DynamicExecutors]

ClassNotFoundException[org.elasticsearch.common.util.concurrent.DynamicExecutors]2)
NoClassDefFoundError[org/elasticsearch/common/util/concurrent/
DynamicExecutors]

Any ideas?


(system) #3