64bit OSes and VM sizes


(davrob) #1

Hi,

I've been getting the following error when I set "ES_MAX_MEM=4g" in
elasticsearch.in.sh:

                   Invalid maximum heap size: -Xmx4g

                   The specified size exceeds the maximum

representable size.

Can I check, that the elastic search startup scripts support 64bit
mode "out of the box" without me putting "-d64" or "-server" in any of
the JAVA_OPTS in the script?

Its possible that this could be due to a config setting on our
corporate VMs, even though we appear to have 48gigs of VM free, but I
wanted to make sure that I didn't have to start fiddling with the
default settings in the script.

Best Regards,

David.


(Shay Banon) #2

You can pass custom scripts using ES_JAVA_OPTS, and force a 64bit VM. It really depends on installation of the JVM and what it defaults to. By default, ES will use which java if no JAVA_HOME is set to get the java version, and use it as is.

On Saturday, June 18, 2011 at 6:45 PM, davrob2 wrote:

Hi,

I've been getting the following error when I set "ES_MAX_MEM=4g" in
elasticsearch.in.sh (http://elasticsearch.in.sh):

Invalid maximum heap size: -Xmx4g

The specified size exceeds the maximum
representable size.

Can I check, that the elastic search startup scripts support 64bit
mode "out of the box" without me putting "-d64" or "-server" in any of
the JAVA_OPTS in the script?

Its possible that this could be due to a config setting on our
corporate VMs, even though we appear to have 48gigs of VM free, but I
wanted to make sure that I didn't have to start fiddling with the
default settings in the script.

Best Regards,

David.


(system) #3