ES fails to start when using 64 bit java

I have been using ES for a few months now without many problems. I have
started running curl search commands that could be considered heavy which
causes the cpu and memory usage to spike. ES consumes the 3gigs of memory
it has been given then produces out of memory heap errors and hangs. This
system has 32gigs of memory so I tried setting min/max to 8 gigs of memory
and restart ES passing JAVA_OPTS="$JAVA_OPTS -d64" in the start-up script.
You can tell it is using the 64 bit version of java as it produces
an Invalid initial heap size: -Xms8g error if it tries the 32 bit version.
I have tried multiple versions of java, all with the same error. Thank
you in advance for any help.

Gist of error log: https://gist.github.com/rmelissari/5346017
ES Version: .20.5
JVM: 1.6.0.25, 1.6.0.43, 1.7.0.17
Configuration: Default configuration
Operating System: Sparc Solaris 10 update 11
Nodes: 1
Indices: 68
Shards: 5
ES_Min_Mem = 3g
ES_Max_Mem = 3g

[root]@logtest /export/logs/root/elasticsearch/bin> (09:11:03 04/08/13)
:: ./elasticsearch -f &
[1] 28309

[root]@logtest /export/logs/root/elasticsearch/bin> (09:11:05 04/08/13)
:: [2013-04-09 09:11:12,606][INFO ][node ] [Xorr the
God-Jewel] {0.20.5}[28309]: initializing ...
[2013-04-09 09:11:12,678][INFO ][plugins ] [Xorr the
God-Jewel] loaded [], sites [paramedic]

A fatal error has been detected by the Java Runtime Environment:

SIGBUS (0xa) at pc=0xffffffff7e176c08, pid=28309, tid=2

JRE version: 6.0_43-b01

Java VM: Java HotSpot(TM) 64-Bit Server VM (20.14-b01 mixed mode

solaris-sparc compressed oops)

Problematic frame:

V [libjvm.so+0x976c08] Unsafe_GetLong+0x120

An error report file with more information is saved as:

/export/logs/root/elasticsearch/bin/hs_err_pid28309.log

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Are you using mlockall by any chance? Nothing else comes to mind.

--
Ivan

On Tue, Apr 9, 2013 at 7:22 AM, ryan.melissari@gmail.com wrote:

I have been using ES for a few months now without many problems. I have
started running curl search commands that could be considered heavy which
causes the cpu and memory usage to spike. ES consumes the 3gigs of memory
it has been given then produces out of memory heap errors and hangs. This
system has 32gigs of memory so I tried setting min/max to 8 gigs of memory
and restart ES passing JAVA_OPTS="$JAVA_OPTS -d64" in the start-up script.
You can tell it is using the 64 bit version of java as it produces
an Invalid initial heap size: -Xms8g error if it tries the 32 bit version.
I have tried multiple versions of java, all with the same error. Thank
you in advance for any help.

Gist of error log: https://gist.github.com/rmelissari/5346017
ES Version: .20.5
JVM: 1.6.0.25, 1.6.0.43, 1.7.0.17
Configuration: Default configuration
Operating System: Sparc Solaris 10 update 11
Nodes: 1
Indices: 68
Shards: 5
ES_Min_Mem = 3g
ES_Max_Mem = 3g

[root]@logtest /export/logs/root/elasticsearch/bin> (09:11:03 04/08/13)
:: ./elasticsearch -f &
[1] 28309

[root]@logtest /export/logs/root/elasticsearch/bin> (09:11:05 04/08/13)
:: [2013-04-09 09:11:12,606][INFO ][node ] [Xorr the
God-Jewel] {0.20.5}[28309]: initializing ...
[2013-04-09 09:11:12,678][INFO ][plugins ] [Xorr the
God-Jewel] loaded [], sites [paramedic]

A fatal error has been detected by the Java Runtime Environment:

SIGBUS (0xa) at pc=0xffffffff7e176c08, pid=28309, tid=2

JRE version: 6.0_43-b01

Java VM: Java HotSpot(TM) 64-Bit Server VM (20.14-b01 mixed mode

solaris-sparc compressed oops)

Problematic frame:

V [libjvm.so+0x976c08] Unsafe_GetLong+0x120

An error report file with more information is saved as:

/export/logs/root/elasticsearch/bin/hs_err_pid28309.log

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Tuesday, April 9, 2013 9:31:57 AM UTC-5, Ivan Brusic wrote:

Are you using mlockall by any chance? Nothing else comes to mind.

--
Ivan

I am not, unless it is a default setting, but that is a good idea looking
at itsdescription. The instructions are not very clear on where to set
bootstrap.mlockall to true. Where would this be done at?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You mention three JVMs, and you quote a JVM SIGBUS coredump with Java
1.6.0_43. Does SIGBUS also happen on 1.7.0_17? Note, this is an issue
with your JVM, not with Elasticsearch.

Jörg

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.