Adding node configurations to elasticsearch.yml file doesn't work


(Jiwon Cha) #1

Hello. I'm new to elasticsearch and I'm trying to change the configuration file.
So I uncommented cluster.name and node.name lines and renamed them, which work fine after waiting for a few seconds. However, I tried adding the following lines after node.name and it stops working (connection refused):

node.master: false
node.data: true
index.number_of_shards: 5
index.number_of_replicas: 1
network.host: 0.0.0.0
transport.tcp.port: 9301
transport.tcp.compress: true
http.port: 9201
http.enabled: true
discovery.zen.minimum_master_nodes: 1
discovery.zen.ping.timeout: 10s
discovery.zen.ping.multicast.enabled: false
discovery.zen.ping.unicast.hosts: ["127.0.0.1:9300"]

Any suggestions?


(Mark Walkom) #2

Please paste the log showing startup.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.