After enabling true in elasticsearch kibana url is saying kibana server is not ready

Hello, I am using basic version of Elastic and kibana 7.9. after configuration am not able to see Users and roles tab under stack-management. so tried enabling xpack in elasticsearch.yml file.after enabling and starting elasticsearch service. Kibana url is not loading getting "Kiabana server is not ready.

It might be due to communication encryption between elasticsearch and kibana.

You can see the logs of kibana for detailed error.

By enabling http & ssl encryption on elasticsearch this can be resolved.

Hi, I dont see any kibana.log is created under /var/log/.. in kibana.yml file i see logging.dest: stdout as log destination..where i can find logs if it mention like this.

Also, can you please let me know what parameter i have to update in elasticsearch.yml for http enablement.

If i update logging.dest:/var/log/kibana.log kibana service is not restarting.

You can see the logs by running journalctl -xe

I have enabled true and true in elasticsearch.yaml and restarted service. now kibana is showing "Kibana server is not ready yet",but kibana service is running.

Logs from elasticsearch.log
[2020-09-22T13:43:38,254][INFO ][o.e.x.s.a.AuthenticationService] [el9512] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]
[2020-09-22T13:43:40,776][INFO ][o.e.x.s.a.AuthenticationService] [el9512] Authentication of [elastic] was terminated by realm [reserved] - failed to authenticate user [elastic]

But kibana service is running.
● kibana.service - Kibana
Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: disabled)
Active: active (running) since Tue 2020-09-22 13:41:12 CEST; 14min ago
Main PID: 87611 (node)
CGroup: /system.slice/kibana.service
└─87611 /usr/share/kibana/bin/../node/bin/node /usr/share/kibana/bin/../src/cli

Did you run the below command to set-up users and passwords.

/usr/share/elasticsearch/bin/elasticsearch-setup-passwords interactive

if not run the above command and set the passwords. later add the username and password to kibana.yml

Perfect !! It worked as expected.. Thanks a lot !!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.