After "service elasticsearch start" it crashes


(tomer zaks) #1

Hi everyone,

I am new to ElasticSearch, I tried to create a new VM with version 5.2 of ES. I did so with an rpm file.

After all the process i try to start ES by "service elasticsearch start" and it works fine!
After checking status for a few second i get a result as following:

I have JRE 1.8.0_112 and did not change any config. except the name of the host and port number.

Will be happy for any help :smile:

Many thanks,

Tomer Zaks


(Mark Walkom) #2

Please don't post pictures of text, they are difficult to read and some people may not be even able to see them :slight_smile:

Have you looked at the logs for Elasticsearch?


(tomer zaks) #3

Thanks for the notice will try not to post them, :thumbsup:
Now I found the logs and found this (didnt know how to open logs until now):

"[2017-02-12T10:24:34,155][WARN ][o.e.b.BootstrapChecks ] [mNBvEp6] max number of threads [1024] for user [elasticsearch] is too low, increase to at least [2048]
[2017-02-12T10:24:34,156][WARN ][o.e.b.BootstrapChecks ] [mNBvEp6] system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk"

After a check on the net I got this option:

"When using the RPM or Debian packages on systems that use systemd, system limits must be specified via systemd.

The systemd service file (/usr/lib/systemd/system/elasticsearch.service) contains the limits that are applied by default.

To override these, add a file called /etc/systemd/system/elasticsearch.service.d/elasticsearch.conf and specify any changes in that file, such as:

[Service]
LimitMEMLOCK=infinity"

But the VM does not allow me to save the new file


(Mark Walkom) #5

What does this mean exactly?


(tomer zaks) #7

Actually I did a dumb mistake... I dont have systemd at all since I am working on CentOs 6...
On CentOs 6 i saw that I have to set bootstrap.memory_lock: to false, but also this crashes ElasticSearch and gives me:

system call filters failed to install; check the logs and fix your configuration or disable system call filters at your own risk

any help will be great


(tomer zaks) #8

Well the solution to this problem was to enter a line:

"bootstrap.system_call_filter: false" to elasticsearch.yml.


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.