Unable to start Elasticsearch service in centos

Recently setup elk stack, but unable to start the es service, its throwing the below error when i run "journalctl -xe"

Also the logs of elasticsearch

Can someone help me on this?

I think it's selinux, disable it to test.

Hi, selinux is already disabled in the machine

Check your configuration file. Errors in the syntax can cause this.

Please don't post pictures of text, they are difficult to read, impossible to search and replicate (if it's code), and some people may not be even able to see them :slight_smile:

I dealt with those types of errors a few times on CentOS 8. Are you getting any indication of a problem if you tail your log elasticsearch.log, considering log is at default location if you installed with rpm.

systemctl restart elasticsearch && tail -f /var/log/elasticsearch/elasticsearch.log

I dont get any logs, which causes this service failing, I have attached the same log in my first message itself.

Elasticsearch docs state this, have you done this to help diagnose the issue:

By default the Elasticsearch service doesn’t log information in the systemd journal. To enable journalctl logging, the --quiet option must be removed from the ExecStart command line in the elasticsearch.service file.

Another thought, are you always attempting to start elasticsearch with systemctl? What happens if you try to start elasticsearch by method below, while using needed arguments? I suggest this to pinpoint if error is related to your systemctl service configuration or the underlying file/folders that systemctl is interacting with.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.