After upgrade to 7.0.1 filebeat is complaining about a license

(Walker Rowe) #1

After apt-get remove elasticsearch to remove version 6.x and then downloading version 7.0.1 ES and installing it with dpkg ES starts fine. In other words I kept my cluster config files the same. But filebeat is complaining about a license. Yet none of the license APIs work, leading me to believe I do have the open source ES. Is filebeat no longer open source?

[/_license

{"error":{"root_cause":[{"type":"master_not_discovered_exception","reason":null}],"type":"master_not_discovered_exception","reason":null},"status":503}](http://)

elasticsearch-7.0.1-amd64.deb filebeat-7.0.1-amd64.deb

Connection marked as failed because the onConnect callback failed: invalid license found, requires a basic or a valid trial license and received Open source

This thread is close but not exactly the issue I faced.

(Martin R.) #2

Hi,

The package you reference are the ones using the Elastic license and not the ones using the OSS license. Basically your using the default distribution of elasticsearch and filebeat and not the OSS distribution. If your not familiar with all that you should check the subscription page to understand the differences. I don’t think your issue is related to any of that, and once you understand the licenses you’ll probably use exactly the packages you’re using now.

Now your error indicate your elasticsearch cluster (or single node cluster) has not formed correctly. ES might be running but there is more to it than that. It also needs to form a valid “cluster”, even if its a single node. That because there needs to be a master.

It doesn’t appear you have read the doc/release notes/breaking changes for version 7 since you say you kept your config the same. That’s not going to work. Hence the error about not discovering a master.

I recommend reading the logs of your ES node which you haven’t shared here, instead of the filebeat logs. Also the install docs for es 7, with the breaking changes too. You’ll see there are new settings required to start a 7.x ES. I’m thinking those required settings are not in your conf, which you haven’t shared here.

You’ll be on the right path I think.
As for the filebeat error message, I currently think this is a misleading error message because filebeat thinks your mixing OSS ES with Elastic license filebeat. I think filebeat is confused because it cannot call the license endpoint, but in this case the reason why it can’t is because your ES is not healthy and has not formed a working and valid ES cluster.

(Walker Rowe) #3

Perfect. That fixed the issue. Not sure how to mark this issue as closed but it's closed now.

The reason I wanted to keep the old config was so I did not have to put all the cluster config items back in.