Allow only localhost access

How can allow only local requests for elasticsearch? So command like:

curl -XGET 'http://localhost:9200/twitter/_settings'

can only be running on localhost and request like:

curl -XGET 'http://mydomain.com:9200/twitter/_settings'

would get rejected?

Because, from what i see, elasticsearch allows it by default.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey,

see http://www.elasticsearch.org/guide/reference/modules/network.html
check for the network.bind_host parameter

On Tue, Mar 19, 2013 at 4:22 PM, Samuel Molnar molnar.samuel@gmail.comwrote:

How can allow only local requests for elasticsearch? So command like:

curl -XGET 'http://localhost:9200/twitter/_settings'

can only be running on localhost and request like:

curl -XGET 'http://mydomain.com:9200/twitter/_settings'

would get rejected?

Because, from what i see, elasticsearch allows it by default.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.