To run Elastic Search on localhost

Hi All,

I want the elastic search to listen on the ports - 9300 to 9400 and 9200
by only localhost. I have set the bind and publish host as the default :
192.168.0.1 only.Also, in the url as well i am using localhost. But still
it listens on this port from everywhere, even though I have not asked for
it to listen.

So it seems I am missing some configuration. Any pointers here?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

Hey,

can you post your configuration maybe, as it is easier to check.
Also calling netstat -tulpe (for Linux, no sure about mac os x) shows, that
elasticsearch is bound to all ips?
In addition it would be useful to know the elasticsearch version you are
using.

--Alex

On Thu, Jun 6, 2013 at 2:07 PM, Kaushal kaush.mu@gmail.com wrote:

Hi All,

I want the elastic search to listen on the ports - 9300 to 9400 and 9200
by only localhost. I have set the bind and publish host as the default :
192.168.0.1 only.Also, in the url as well i am using localhost. But still
it listens on this port from everywhere, even though I have not asked for
it to listen.

So it seems I am missing some configuration. Any pointers here?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

On Thursday 06 June 2013 05:37 PM, Kaushal wrote:

Hi All,

I want the elastic search to listen on the ports - 9300 to 9400 and
9200 by only localhost. I have set the bind and publish host as the
default :
192.168.0.1 only.Also, in the url as well i am using localhost. But
still it listens on this port from everywhere, even though I have not
asked for it to listen.
Assuming you have 3 interfaces in your system
eth0 at 192.168.0.1
lo at 127.0.0.1
wlan0 at 192.168.1.1

if u set bind_host to 0.0.0.0 . it is going to listen on all interfaces
if u set bind_host to 192.168.0.1. it is going to listen on eth0
if u set bind_host to 127.0.0.1. it is goint to listen on lo which
serves all localhost queries.
by default publish_host the first interface it finds other than
bind_host. But you can set it to 0.0.0.0 to listen on all no lo interfaces.

According to your requirement.

  • bind_host should be 127.0.0.1
  • publish_host seems ok with your requirement.

So it seems I am missing some configuration. Any pointers here?

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.