How to get Elasticsearch to listen to site IP address?

I am trying to get Elasticsearch to listen to IP addresses other than I have edited the /etc/elasticsearch.yml file as follows: ["local", "site"] -- tried this one first but didn't work [ "local:ipv4" , "site:ipv4" ]
http.port: 9200
netstat shows that it seems to be listening on the port:
$ sudo netstat -anp|grep 9200
tcp6 0 0 :::* LISTEN 31495/java
tcp6 0 0 :::* LISTEN 31495/java

curl results are as expected:
"name" : "1_im18G",
"cluster_name" : "elasticsearch",
"cluster_uuid" : "bsw9TRs8SvakK5WDVeM5xQ",
"version" : {
"number" : "5.2.0",
"build_hash" : "24e05b9",
"build_date" : "2017-01-24T19:52:35.800Z",
"build_snapshot" : false,
"lucene_version" : "6.4.0"
"tagline" : "You Know, for Search"
and the change from netstat:
sudo netstat -anp|grep 9200
tcp 0 0 TIME_WAIT -
tcp6 0 0 :::* LISTEN 31495/java
tcp6 0 0 :::* LISTEN 31495/java

response to curl though results in:

<TITLE>Network Error - tcp_error</title>
Network Error (tcp_error)</b> </font> </p>
<p><font face="Arial, Helvetica, sans-serif" size="2"> A communication error occurred: "Operation timed out"
        </font> </p>
      <p><font face="Arial, Helvetica, sans-serif" size="2"> The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may wish to try again at a later time.

and no change to netstat.
tcp6 0 0 :::* LISTEN 31495/java
tcp6 0 0 :::* LISTEN 31495/java

Am I missing something or is there maybe a server networking issue?

The issue was resolved with setting the no_proxy on the local network devices to include the sever.

Is there any software which can protect the laptop from virus? I am fed up with the virus issue because it attacked my laptop for the third time and I lost my data twice, now I don’t want to lose it again. The person whom I contacted to get the Help With Assignment told me to install an anti-virus, but it didn’t work. Can anyone here help me by telling me the name of a reliable anti-virus; I am willing to pay any amount to buy it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.