Elasticsearch does not listen on ipv4

Hello, my dears,
I installed Elasticsearch on my Debian Buster Server. The following ports have been opened.

root@dsme01:~# netstat -tulpen | grep
tcp6       0      0     :::*                    LISTEN      137        487760242  19429/java          
tcp6       0      0     :::*                    LISTEN      137        487760026  19429/java  

I notice that only ipv6 connections are displayed. Why?
My elsaticsearch.yml looks like this

root@dsme01:~# cat /etc/elasticsearch/elasticsearch.yml 
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
network.host: elasticsearch.intern.example.com
xpack.security.enabled: true
xpack.security.enrollment.enabled: true
  enabled: true
  keystore.path: certs/http.p12
  enabled: true
  verification_mode: certificate
  keystore.path: certs/transport.p12
  truststore.path: certs/transport.p12
cluster.initial_master_nodes: ["dsme01"]
http.host: elasticsearch.intern.example.com
transport.host: elasticsearch.intern.example.com
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch

What am I doing wrong?

Greetings from Stefan Harbich

Are you referring to the tcp6 in the netstat output? That's normal, or at least not unexpected in certain configs, and doesn't indicate a problem. There's some sort of compatibility layer in play that makes these sockets appear to be using IPv6 but the addresses are IPv4 addresses and that's what really matters.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.