Analysing and Searching


(deep saxena) #1

I am configuring standard tokenizer and lowercase and I am able to perform
good search, like words between sentence, key value pair.

Index Settings

index:
analysis:
analyzer:
# set standard analyzer with no stop words as the default for both
indexing and searching
default_index:
type: custom
tokenizer: standard
filter: [standard,lowercase]

My concern is that When I search A=B then get the result for A, B and A=B
three of them, IF i make it to whitespace then it solves my problem but not
able to search words between the sentences.
How can I keep that A=B should not tokenize A=B and retains as it is, and
want to retain the Index setting

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3b253330-0d6d-4a36-b2d0-6c63f08522d1%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #2

You can use a the pattern tokenizer. If you configure it with the same
delimiters as the standard tokenizer with the exception of '=', your
queries should work.

--
Ivan

On Sun, Dec 15, 2013 at 1:30 AM, deep saxena sandy100ster@gmail.com wrote:

I am configuring standard tokenizer and lowercase and I am able to
perform good search, like words between sentence, key value pair.

Index Settings

index:
analysis:
analyzer:
# set standard analyzer with no stop words as the default for both
indexing and searching
default_index:
type: custom
tokenizer: standard
filter: [standard,lowercase]

My concern is that When I search A=B then get the result for A, B and A=B
three of them, IF i make it to whitespace then it solves my problem but not
able to search words between the sentences.
How can I keep that A=B should not tokenize A=B and retains as it is, and
want to retain the Index setting

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3b253330-0d6d-4a36-b2d0-6c63f08522d1%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQAQMgR6hqTjsczpiC9ztnBA9g-7qbgEWEjBhDDq1qp2fw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(deep saxena) #3

can you give example of the regex that we can use??

On Monday, 16 December 2013 22:46:30 UTC+5:30, Ivan Brusic wrote:

You can use a the pattern tokenizer. If you configure it with the same
delimiters as the standard tokenizer with the exception of '=', your
queries should work.

--
Ivan

On Sun, Dec 15, 2013 at 1:30 AM, deep saxena <sandy1...@gmail.com<javascript:>

wrote:

I am configuring standard tokenizer and lowercase and I am able to
perform good search, like words between sentence, key value pair.

Index Settings

index:
analysis:
analyzer:
# set standard analyzer with no stop words as the default for both
indexing and searching
default_index:
type: custom
tokenizer: standard
filter: [standard,lowercase]

My concern is that When I search A=B then get the result for A, B and A=B
three of them, IF i make it to whitespace then it solves my problem but not
able to search words between the sentences.
How can I keep that A=B should not tokenize A=B and retains as it is,
and want to retain the Index setting

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/3b253330-0d6d-4a36-b2d0-6c63f08522d1%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1780a023-5a01-4eb4-8f90-11dfafaad1e4%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4