Stopping analyzer to apply on the search part


(deep saxena) #1

Hey,

I am indexing my data using this configuration in .yml file like this

Index Settings

index:
analysis:
analyzer:
# set standard analyzer with no stop words as the default for both
indexing and searching
default:
type: custom
tokenizer:
filter: [standard,lowercase]

default will apply to both while indexing and searching.
What is happening tokenization is taking place on the special character.
That is okay, But I want that while searching tokenization of my string
should not take place.
I tried all the parts like default_index and index_analyzer setting in the
.yml file and template respectively. But I did achive any thing.
Can Naybody help in this matter. It would be appreciated.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/160c2891-79d0-449a-9af4-f58a3cbf0c87%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #2