Another Kibana instance appears to be migrating the index

i restart kibana,and i got the error log:"Another Kibana instance appears to be migrating the index. Waiting for that migration to complete. If no other Kibana instance is attempting migrations, you can get past this message by deleting index .kibana_1 and restarting Kibana."
i tried curl -XDELETE http://localhost:9200/.kibana_1, it didn't work
all version of logstash elasticsearch kibana are 6.5.4
i have the basic license, so don't support security.
i tried curl -X PUT http://localhost:9200/_all/_settings -H 'Content-Type: application/json' -d'{ "index.blocks.read_only_allow_delete" : false } }'
responese:{"acknowledged":false}
i reinstall elasticsearch and kibana, don't work.
i have iptables deny any 9200 9300 port incoming connect. only 127.0.0.1.

Thanks for the report. This issue is caused by stopping the process which is in charge of handling the migration. This "locking" is to handle having multiple Kibana instances. Probably same as the issue here: https://github.com/elastic/kibana/issues/25464

Rashmi

1 Like

it just repeat the same error after i use curl -XDELETE http://localhost:9200/.kibana_1 to delete the index, and restart kibana.
i user kibana 6.5.4, not kibana 6.5.0.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.