Any bulletproof online resources for setting up ES on an Amazon micro EC2 instance?


(Ryan Cassano) #1

Hi all --

New to ec2/S3 and ES and working through some growing pains. I have
followed the instructions via
http://www.elasticsearch.org/tutorials/elasticsearch-on-ec2/ and can't seem
to find where to set my env. var's for the likes of ES_MIN_MEM, etc.

Do you know of any URLs or videos that outline this process step by step?

The EC site seems a little short on details and there seems to be a lot of
conflicting issues with different users when setting this up.

Thanks so much!

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3312afc5-e345-477e-a57b-d9f35ec83c81%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Michael Lussier) #2

If you're on a debian-based system, you can declare vars inline like so:

ES_MAX_MEM=2gb /usr/local/bin/elasticsearch -f

And when you're in production, and using the service wrapper, declare those vars in /etc/init.d/elasticsearch, If you just want it to work, be fast, and reliable check us out at qbox.io ;).


(David Pilato) #3

That say, on a micro instance, I don't believe you need to set memory settings! :slight_smile:
You have around 700 Mb RAM available iirc.

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 6 déc. 2013 à 02:27, Michael Lussier michael@stacksearch.com a écrit :

If you're on a debian-based system, you can declare vars inline like so:

ES_MAX_MEM=2gb /usr/local/bin/elasticsearch -f

And when you're in production, and using the service wrapper, declare those
vars in /etc/init.d/elasticsearch, If you just want it to work, be fast, and
reliable check us out at qbox.io http://qbox.io ;).


--
View this message in context: http://elasticsearch-users.115913.n3.nabble.com/Any-bulletproof-online-resources-for-setting-up-ES-on-an-Amazon-micro-EC2-instance-tp4045569p4045575.html
Sent from the ElasticSearch Users mailing list archive at Nabble.com.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/1386293226531-4045575.post%40n3.nabble.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/F687D1D2-0AAE-4D4B-A09A-D2B83DB322C1%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(Karel Minarik) #4

You need to set the ES_HEAP_SIZE environment variable to some reasonable value (~300MB?), and disable the bootstrap.mlockall setting, micros and weak VMs have trouble with it.

Also, install ES from the official deb/rpm packages, so you don't wrestle with the settings being applied.

Lastly, note that a micro instance is useful mainly for testing/evaluation, or a system with very low demands.

Karel

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/e8d02904-3734-4632-9520-404d477e6437%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ryan Cassano) #5

Thanks everyone. Got it up and working, now trying to figure Kibana and how
it queries. Probably post a new topic!

Anyway thanks again.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d070a0dd-0e65-4f82-a476-57277e7ec05a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #6

I played around with microinstances in the past. I would use a 32-bit
instance/JVM whenever possible since there is no need larger object
references, although the JVM will compress the object references for heaps
under 32GB.

Cheers,

Ivan

On Sun, Dec 8, 2013 at 7:40 AM, Ryan Cassano ryancassano@gmail.com wrote:

Thanks everyone. Got it up and working, now trying to figure Kibana and
how it queries. Probably post a new topic!

Anyway thanks again.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d070a0dd-0e65-4f82-a476-57277e7ec05a%40googlegroups.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CALY%3DcQCyDFC_LjjU7BMm3%3DLjfyT7R3EOrM7sjxVd2%2BCwTaskKw%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #7