ES_MIN_MEM and ES_MAX_MEM settings


(Ashwin Sathya) #1

HI,

My ES setup ran out of heap space and is throwing
"java.lang.OutOfMemoryError: Java heap space"

I understand I have to configure the ES_MAX_MEM environment variable. Now,
ES is the only process running on the machine (i.e) it is a dedicated search
server. My VM runs on a 14 G available run. I want to give maximum memory to
ES. Is it recommended that I set it to 12-13 G (leaving 1-2G for OS) ?

Thanks,

AshwinSa

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Alexander Reelsen) #2

Hey,

usually you should give the ES process half of your available RAM, as the
other RAM then is used to cache files in memory for faster access
(resulting in faster searches).

Maybe it might make sense to find out, why you are getting these OOM
exceptions. Do you know what triggers them?

--Alex

On Fri, Sep 13, 2013 at 8:50 AM, R Ashwin Sathya
ashwin.sathya@outlook.comwrote:

HI,****


My ES setup ran out of heap space and is throwing
“java.lang.OutOfMemoryError: Java heap space”****

I understand I have to configure the ES_MAX_MEM environment variable. Now,
ES is the only process running on the machine (i.e) it is a dedicated
search server. My VM runs on a 14 G available run. I want to give maximum
memory to ES. Is it recommended that I set it to 12-13 G (leaving 1-2G for
OS) ?****


Thanks,****

AshwinSa****

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ashwin Sathya) #3

Okay. Perfect. I will use a 7G as a setting then.

My hypothesis for OOM is I was running a large data pump to push data
(3-node cluster around 200 million documents) and the MAX_SIZE was set to 1G

Thanks,

Ashwin Sathya

From: elasticsearch@googlegroups.com [mailto:elasticsearch@googlegroups.com]
On Behalf Of Alexander Reelsen
Sent: September 13, 2013 12:46
To: elasticsearch@googlegroups.com
Subject: Re: ES_MIN_MEM and ES_MAX_MEM settings

Hey,

usually you should give the ES process half of your available RAM, as the
other RAM then is used to cache files in memory for faster access (resulting
in faster searches).

Maybe it might make sense to find out, why you are getting these OOM
exceptions. Do you know what triggers them?

--Alex

On Fri, Sep 13, 2013 at 8:50 AM, R Ashwin Sathya <ashwin.sathya@outlook.com
mailto:ashwin.sathya@outlook.com > wrote:

HI,

My ES setup ran out of heap space and is throwing
"java.lang.OutOfMemoryError: Java heap space"

I understand I have to configure the ES_MAX_MEM environment variable. Now,
ES is the only process running on the machine (i.e) it is a dedicated search
server. My VM runs on a 14 G available run. I want to give maximum memory to
ES. Is it recommended that I set it to 12-13 G (leaving 1-2G for OS) ?

Thanks,

AshwinSa

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com
mailto:elasticsearch%2Bunsubscribe@googlegroups.com .
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com
mailto:elasticsearch+unsubscribe@googlegroups.com .
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4