ElasticSearch Memory settings


(Ciprian-2) #1

Hi,

I'm a beginner in elasticsearch. I'm using also ubuntu for
elasticsearch(version 1.1.0). My issue : where should I set the
ES_MIN/MAX_SIZE(= ES_HEAP_SIZE)? In /etc/elasticsearch/elasticsearch.yml or
/etc/default/elasticsearch or /etc/init.d/elasticsearch? From what i read i
should set the ES_MIN/MAX_SIZE = ram / 2.
My application is reading data from a Sqs and pushing it to elasticseach.
This is done from 2 consumers each with a thread pool of 5 threads. That
means 10 threads who are inserting documents in elasticsearch. I have a
separate server for elasticsearch with 8gb of ram.
From my configuration : I set ES_MIN/MAX_SIZE = 4g(=ram / 2) only in
/etc/elasticsearch/elasticsearch.yml and restarting the elasticsearch. When
I call the htop, I see for elasticsearch user the next command which is
duplicated(..10 threads => more line like this one) :
/usr/lib/jvm/java-7-openjdk-amd64//bin/java -Xms256m -Xmx1g -Xss256k
-Djava.awt. Shouldn't it be -Xms2g -Xmx2g, because I set in
elasticsearch.yml 2g?

  1. From what i read in other posts I should set this in "service wrapper
    configuration". But which file is linked to "service wrapper configuration"
    /etc/default/elasticsearch or /etc/init.d/elasticsearch?
  2. Should I have same values in elasticsearch.yml ES_MIN_MEM/ES_MAX_MEM
    like in "service wrapper configuration" (ES_HEAP_SIZE) ?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/c4dcdd58-6f8e-46dd-afbb-a9ec940513e8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.


(Mark Walkom) #2

As per my other response - /etc/default/elasticsearch for ubuntu/debian

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 11 June 2014 19:22, Ciprian turcanciprian87@gmail.com wrote:

Hi,

I'm a beginner in elasticsearch. I'm using also ubuntu for
elasticsearch(version 1.1.0). My issue : where should I set the
ES_MIN/MAX_SIZE(= ES_HEAP_SIZE)? In /etc/elasticsearch/elasticsearch.yml or
/etc/default/elasticsearch or /etc/init.d/elasticsearch? From what i read i
should set the ES_MIN/MAX_SIZE = ram / 2.
My application is reading data from a Sqs and pushing it to elasticseach.
This is done from 2 consumers each with a thread pool of 5 threads. That
means 10 threads who are inserting documents in elasticsearch. I have a
separate server for elasticsearch with 8gb of ram.
From my configuration : I set ES_MIN/MAX_SIZE = 4g(=ram / 2) only in
/etc/elasticsearch/elasticsearch.yml and restarting the elasticsearch. When
I call the htop, I see for elasticsearch user the next command which is
duplicated(..10 threads => more line like this one) :
/usr/lib/jvm/java-7-openjdk-amd64//bin/java -Xms256m -Xmx1g -Xss256k
-Djava.awt. Shouldn't it be -Xms2g -Xmx2g, because I set in
elasticsearch.yml 2g?

  1. From what i read in other posts I should set this in "service wrapper
    configuration". But which file is linked to "service wrapper configuration"
    /etc/default/elasticsearch or /etc/init.d/elasticsearch?
  2. Should I have same values in elasticsearch.yml ES_MIN_MEM/ES_MAX_MEM
    like in "service wrapper configuration" (ES_HEAP_SIZE) ?

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/c4dcdd58-6f8e-46dd-afbb-a9ec940513e8%40googlegroups.com
https://groups.google.com/d/msgid/elasticsearch/c4dcdd58-6f8e-46dd-afbb-a9ec940513e8%40googlegroups.com?utm_medium=email&utm_source=footer
.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624a4ErfdhfGuV6Exjy37bT80ZGeusOKYedK%3D%3D90K_xOZVQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.


(system) #3