Set ES_MIN_MEM in elasticsearch.yml not work


(lijionly) #1

Hi,
I'm using elasticsearch 0.90.2, install elasticsearch with wrapper. And
modify elasticsearch.yml as below:
ES_MIN_MEM: 2048m
ES_MAX_MEM: 2048m

restart elasticsearch service.
check es process and found it starts with -Xms1024m -Xmx1024m, should it
be changed to 2048m?

ps -ef|grep elasticsearch
501 6615 1 0 01:57 pts/0 00:00:12 /usr/local/java/bin/java
-Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Delasticsearch -Des.path.home=/usr/local/elasticsearch -cp
:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/local/elasticsearch/lib/:/usr/local/elasticsearch/lib/sigar/
org.elasticsearch.bootstrap.ElasticSearch
501 9291 1 0 02:19 ? 00:00:00
/usr/local/elasticsearch/bin/service/exec/elasticsearch-linux-x86-64
/usr/local/elasticsearch/bin/service/elasticsearch.conf
wrapper.syslog.ident=elasticsearch
wrapper.pidfile=/usr/local/elasticsearch/bin/service/./elasticsearch.pid
wrapper.name=elasticsearch wrapper.displayname=ElasticSearch
wrapper.daemonize=TRUE
wrapper.statusfile=/usr/local/elasticsearch/bin/service/./elasticsearch.status
wrapper.java.statusfile=/usr/local/elasticsearch/bin/service/./elasticsearch.java.status
wrapper.script.version=3.5.14
501 9293 9291 16 02:20 ? 00:00:05
/usr/local/jdk1.6.0_34/bin/java -Delasticsearch-service
-Des.path.home=/usr/local/elasticsearch -Xss256k -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Djava.awt.headless=true -Xms1024m -Xmx1024m
-Djava.library.path=/usr/local/elasticsearch/bin/service/lib -classpath
/usr/local/elasticsearch/bin/service/lib/wrapper.jar:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/local/elasticsearch/lib/jna-3.3.0.jar:/usr/local/elasticsearch/lib/jts-1.12.jar:/usr/local/elasticsearch/lib/log4j-1.2.17.jar:/usr/local/elasticsearch/lib/lucene-analyzers-common-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-codecs-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-core-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-grouping-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-highlighter-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-join-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-memory-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-queries-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-queryparser-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-sandbox-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-spatial-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-suggest-4.3.1.jar:/usr/local/elasticsearch/lib/spatial4j-0.3.jar:/usr/local/elasticsearch/lib/sigar/sigar-1.6.4.jar
-Dwrapper.key=YiWMu02nNu-beU4M -Dwrapper.port=32000
-Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999
-Dwrapper.disable_console_input=TRUE -Dwrapper.pid=9291
-Dwrapper.version=3.5.14 -Dwrapper.native_library=wrapper
-Dwrapper.service=TRUE -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=1
org.tanukisoftware.wrapper.WrapperSimpleApp
org.elasticsearch.bootstrap.ElasticSearchF

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Radu Gheorghe) #2

Hello,

That setting isn't in elasticsearch.yml. Try changing elasticsearch.conf of
the service wrapper:

set.default.ES_HEAP_SIZE=1024

or the ES_HEAP_SIZE environment variable. No "m" is needed in the end, the
size is in MB.

Best regards,
Radu

http://sematext.com/ -- Elasticsearch -- Solr -- Lucene

On Tue, Sep 3, 2013 at 1:19 PM, lijionly@gmail.com wrote:

Hi,
I'm using elasticsearch 0.90.2, install elasticsearch with wrapper. And
modify elasticsearch.yml as below:
ES_MIN_MEM: 2048m
ES_MAX_MEM: 2048m

restart elasticsearch service.
check es process and found it starts with -Xms1024m -Xmx1024m, should it
be changed to 2048m?

ps -ef|grep elasticsearch
501 6615 1 0 01:57 pts/0 00:00:12 /usr/local/java/bin/java
-Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Delasticsearch -Des.path.home=/usr/local/elasticsearch -cp
:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/local/elasticsearch/lib/:/usr/local/elasticsearch/lib/sigar/
org.elasticsearch.bootstrap.ElasticSearch
501 9291 1 0 02:19 ? 00:00:00
/usr/local/elasticsearch/bin/service/exec/elasticsearch-linux-x86-64
/usr/local/elasticsearch/bin/service/elasticsearch.conf
wrapper.syslog.ident=elasticsearch
wrapper.pidfile=/usr/local/elasticsearch/bin/service/./elasticsearch.pid
wrapper.name=elasticsearch wrapper.displayname=ElasticSearch
wrapper.daemonize=TRUE
wrapper.statusfile=/usr/local/elasticsearch/bin/service/./elasticsearch.status
wrapper.java.statusfile=/usr/local/elasticsearch/bin/service/./elasticsearch.java.status
wrapper.script.version=3.5.14
501 9293 9291 16 02:20 ? 00:00:05
/usr/local/jdk1.6.0_34/bin/java -Delasticsearch-service
-Des.path.home=/usr/local/elasticsearch -Xss256k -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Djava.awt.headless=true -Xms1024m -Xmx1024m
-Djava.library.path=/usr/local/elasticsearch/bin/service/lib -classpath
/usr/local/elasticsearch/bin/service/lib/wrapper.jar:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/local/elasticsearch/lib/jna-3.3.0.jar:/usr/local/elasticsearch/lib/jts-1.12.jar:/usr/local/elasticsearch/lib/log4j-1.2.17.jar:/usr/local/elasticsearch/lib/lucene-analyzers-common-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-codecs-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-core-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-grouping-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-highlighter-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-join-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-memory-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-queries-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-queryparser-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-sandbox-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-spatial-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-suggest-4.3.1.jar:/usr/local/elasticsearch/lib/spatial4j-0.3.jar:/usr/local/elasticsearch/lib/sigar/sigar-1.6.4.jar
-Dwrapper.key=YiWMu02nNu-beU4M -Dwrapper.port=32000
-Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999
-Dwrapper.disable_console_input=TRUE -Dwrapper.pid=9291
-Dwrapper.version=3.5.14 -Dwrapper.native_library=wrapper
-Dwrapper.service=TRUE -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=1
org.tanukisoftware.wrapper.WrapperSimpleApp
org.elasticsearch.bootstrap.ElasticSearchF

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(lijionly) #3

Thanks,
I tried elasticsearch.conf as below:
set.default.ES_HOME=
set.default.ES_HEAP_SIZE=1024
set.default.ES_MIN_MEM=256
set.default.ES_MAX_MEM=1024

And restart elasticsearch, but the process still with the -Xms1024m
-Xmx1024m

在 2013年9月3日星期二UTC+8下午7时12分37秒,Radu Gheorghe写道:

Hello,

That setting isn't in elasticsearch.yml. Try changing elasticsearch.conf
of the service wrapper:

set.default.ES_HEAP_SIZE=1024

or the ES_HEAP_SIZE environment variable. No "m" is needed in the end,
the size is in MB.

Best regards,
Radu

http://sematext.com/ -- Elasticsearch -- Solr -- Lucene

On Tue, Sep 3, 2013 at 1:19 PM, <liji...@gmail.com <javascript:>> wrote:

Hi,
I'm using elasticsearch 0.90.2, install elasticsearch with wrapper. And
modify elasticsearch.yml as below:
ES_MIN_MEM: 2048m
ES_MAX_MEM: 2048m

restart elasticsearch service.
check es process and found it starts with -Xms1024m -Xmx1024m, should it
be changed to 2048m?

ps -ef|grep elasticsearch
501 6615 1 0 01:57 pts/0 00:00:12 /usr/local/java/bin/java
-Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Delasticsearch -Des.path.home=/usr/local/elasticsearch -cp
:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/local/elasticsearch/lib/:/usr/local/elasticsearch/lib/sigar/
org.elasticsearch.bootstrap.ElasticSearch
501 9291 1 0 02:19 ? 00:00:00
/usr/local/elasticsearch/bin/service/exec/elasticsearch-linux-x86-64
/usr/local/elasticsearch/bin/service/elasticsearch.conf
wrapper.syslog.ident=elasticsearch
wrapper.pidfile=/usr/local/elasticsearch/bin/service/./elasticsearch.pid
wrapper.name=elasticsearch wrapper.displayname=ElasticSearch
wrapper.daemonize=TRUE
wrapper.statusfile=/usr/local/elasticsearch/bin/service/./elasticsearch.status
wrapper.java.statusfile=/usr/local/elasticsearch/bin/service/./elasticsearch.java.status
wrapper.script.version=3.5.14
501 9293 9291 16 02:20 ? 00:00:05
/usr/local/jdk1.6.0_34/bin/java -Delasticsearch-service
-Des.path.home=/usr/local/elasticsearch -Xss256k -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75
-XX:+UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Djava.awt.headless=true -Xms1024m -Xmx1024m
-Djava.library.path=/usr/local/elasticsearch/bin/service/lib -classpath
/usr/local/elasticsearch/bin/service/lib/wrapper.jar:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/local/elasticsearch/lib/jna-3.3.0.jar:/usr/local/elasticsearch/lib/jts-1.12.jar:/usr/local/elasticsearch/lib/log4j-1.2.17.jar:/usr/local/elasticsearch/lib/lucene-analyzers-common-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-codecs-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-core-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-grouping-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-highlighter-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-join-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-memory-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-queries-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-queryparser-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-sandbox-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-spatial-4.3.1.jar:/usr/local/elasticsearch/lib/lucene-suggest-4.3.1.jar:/usr/local/elasticsearch/lib/spatial4j-0.3.jar:/usr/local/elasticsearch/lib/sigar/sigar-1.6.4.jar
-Dwrapper.key=YiWMu02nNu-beU4M -Dwrapper.port=32000
-Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999
-Dwrapper.disable_console_input=TRUE -Dwrapper.pid=9291
-Dwrapper.version=3.5.14 -Dwrapper.native_library=wrapper
-Dwrapper.service=TRUE -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=1
org.tanukisoftware.wrapper.WrapperSimpleApp
org.elasticsearch.bootstrap.ElasticSearchF

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Ivan Brusic) #4

That is correct, since ES_HEAP_SIZE has precedence. ES_HEAP_SIZE will be
used for both Xms and Xmx.

From elasticsearch.in.sh:

if [ "x$ES_MIN_MEM" = "x" ]; then
ES_MIN_MEM=256m
fi
if [ "x$ES_MAX_MEM" = "x" ]; then
ES_MAX_MEM=1g
fi
if [ "x$ES_HEAP_SIZE" != "x" ]; then
ES_MIN_MEM=$ES_HEAP_SIZE
ES_MAX_MEM=$ES_HEAP_SIZE
fi

The last if statement will overwrite the min/max settings if the heap size
is specified.

Cheers,

Ivan

On Tue, Sep 3, 2013 at 7:09 AM, lijionly@gmail.com wrote:

Thanks,
I tried elasticsearch.conf as below:
set.default.ES_HOME=
set.default.ES_HEAP_SIZE=1024
set.default.ES_MIN_MEM=256
set.default.ES_MAX_MEM=1024

And restart elasticsearch, but the process still with the -Xms1024m
-Xmx1024m

在 2013年9月3日星期二UTC+8下午7时12分37秒,Radu Gheorghe写道:

Hello,

That setting isn't in elasticsearch.yml. Try changing elasticsearch.conf
of the service wrapper:

set.default.ES_HEAP_SIZE=1024

or the ES_HEAP_SIZE environment variable. No "m" is needed in the end,
the size is in MB.

Best regards,
Radu

http://sematext.com/ -- Elasticsearch -- Solr -- Lucene

On Tue, Sep 3, 2013 at 1:19 PM, liji...@gmail.com wrote:

Hi,
I'm using elasticsearch 0.90.2, install elasticsearch with wrapper. And
modify elasticsearch.yml as below:
ES_MIN_MEM: 2048m
ES_MAX_MEM: 2048m

restart elasticsearch service.
check es process and found it starts with -Xms1024m -Xmx1024m, should
it be changed to 2048m?

ps -ef|grep elasticsearch
501 6615 1 0 01:57 pts/0 00:00:12 /usr/local/java/bin/java
-Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+*
UseCMSInitiatingOccupancyOnly -XX:+**HeapDumpOnOutOfMemoryError
-Delasticsearch -Des.path.home=/usr/local/**elasticsearch -cp
:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/
local/elasticsearch/lib/
:/**usr/local/elasticsearch/lib/*sigar/
org.elasticsearch.bootstrap.**ElasticSearch
501 9291 1 0 02:19 ? 00:00:00
/usr/local/elasticsearch/bin/**service/exec/elasticsearch-**linux-x86-64
/usr/local/elasticsearch/bin/**service/elasticsearch.conf
wrapper.syslog.ident=elasticsearch wrapper.pidfile=/usr/local/
elasticsearch/bin/service/./**elasticsearch.pid wrapper.name=elasticsearch
wrapper.displayname=**ElasticSearch wrapper.daemonize=TRUE
wrapper.statusfile=/usr/local/**elasticsearch/bin/service/./**elasticsearch.status
wrapper.java.statusfile=/usr/local/elasticsearch/bin/
service/./elasticsearch.java.**status wrapper.script.version=3.5.14
501 9293 9291 16 02:20 ? 00:00:05
/usr/local/jdk1.6.0_34/bin/**java -Delasticsearch-service
-Des.path.home=/usr/local/*elasticsearch -Xss256k -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+

*UseCMSInitiatingOccupancyOnly -XX:+HeapDumpOnOutOfMemoryError
-Djava.awt.headless=true -Xms1024m -Xmx1024m -Djava.library.path=/usr/

local/elasticsearch/bin/**service/lib -classpath
/usr/local/elasticsearch/bin/service/lib/wrapper.jar:/usr/
local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/
local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/
local/elasticsearch/lib/jna-3.3.0.jar:/usr/local/
elasticsearch/lib/jts-1.12.jar:/usr/local/elasticsearch/
lib/log4j-1.2.17.jar:/usr/local/elasticsearch/lib/
lucene-analyzers-common-4.3.1.jar:/usr/local/elasticsearch/
lib/lucene-codecs-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-core-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-grouping-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-highlighter-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-join-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-memory-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-queries-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-queryparser-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-sandbox-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-spatial-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-suggest-4.3.1.jar:/usr/local/elasticsearch/lib/
spatial4j-0.3.jar:/usr/local/**elasticsearch/lib/sigar/sigar-**1.6.4.jar
-Dwrapper.key=YiWMu02nNu-beU4M -Dwrapper.port=32000
-Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999
-Dwrapper.disable_console_**input=TRUE -Dwrapper.pid=9291
-Dwrapper.version=3.5.14 -Dwrapper.native_library=**wrapper
-Dwrapper.service=TRUE -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=1
org.tanukisoftware.wrapper.**WrapperSimpleApp
org.elasticsearch.bootstrap.**ElasticSearchF

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@**googlegroups.com.

For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(lijionly) #5

Thank you! now I get it.

在 2013年9月4日星期三UTC+8下午11时47分14秒,Ivan Brusic写道:

That is correct, since ES_HEAP_SIZE has precedence. ES_HEAP_SIZE will be
used for both Xms and Xmx.

From elasticsearch.in.sh:

if [ "x$ES_MIN_MEM" = "x" ]; then
ES_MIN_MEM=256m
fi
if [ "x$ES_MAX_MEM" = "x" ]; then
ES_MAX_MEM=1g
fi
if [ "x$ES_HEAP_SIZE" != "x" ]; then
ES_MIN_MEM=$ES_HEAP_SIZE
ES_MAX_MEM=$ES_HEAP_SIZE
fi

The last if statement will overwrite the min/max settings if the heap size
is specified.

Cheers,

Ivan

On Tue, Sep 3, 2013 at 7:09 AM, <liji...@gmail.com <javascript:>> wrote:

Thanks,
I tried elasticsearch.conf as below:
set.default.ES_HOME=
set.default.ES_HEAP_SIZE=1024
set.default.ES_MIN_MEM=256
set.default.ES_MAX_MEM=1024

And restart elasticsearch, but the process still with the -Xms1024m
-Xmx1024m

在 2013年9月3日星期二UTC+8下午7时12分37秒,Radu Gheorghe写道:

Hello,

That setting isn't in elasticsearch.yml. Try changing elasticsearch.conf
of the service wrapper:

set.default.ES_HEAP_SIZE=1024

or the ES_HEAP_SIZE environment variable. No "m" is needed in the end,
the size is in MB.

Best regards,
Radu

http://sematext.com/ -- Elasticsearch -- Solr -- Lucene

On Tue, Sep 3, 2013 at 1:19 PM, liji...@gmail.com wrote:

Hi,
I'm using elasticsearch 0.90.2, install elasticsearch with wrapper. And
modify elasticsearch.yml as below:
ES_MIN_MEM: 2048m
ES_MAX_MEM: 2048m

restart elasticsearch service.
check es process and found it starts with -Xms1024m -Xmx1024m, should
it be changed to 2048m?

ps -ef|grep elasticsearch
501 6615 1 0 01:57 pts/0 00:00:12
/usr/local/java/bin/java -Xms256m -Xmx1g -Xss256k -Djava.awt.headless=true
-XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:**
CMSInitiatingOccupancyFraction**=75 -XX:+**UseCMSInitiatingOccupancyOnly
-XX:+**HeapDumpOnOutOfMemoryError -Delasticsearch
-Des.path.home=/usr/local/**elasticsearch -cp
:/usr/local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/
local/elasticsearch/lib/*:/**usr/local/elasticsearch/lib/*sigar/
org.elasticsearch.bootstrap.**ElasticSearch
501 9291 1 0 02:19 ? 00:00:00
/usr/local/elasticsearch/bin/**service/exec/elasticsearch-**linux-x86-64
/usr/local/elasticsearch/bin/**service/elasticsearch.conf
wrapper.syslog.ident=elasticsearch wrapper.pidfile=/usr/local/
elasticsearch/bin/service/./**elasticsearch.pid wrapper.name=elasticsearch
wrapper.displayname=**ElasticSearch wrapper.daemonize=TRUE
wrapper.statusfile=/usr/local/**elasticsearch/bin/service/./**elasticsearch.status
wrapper.java.statusfile=/usr/local/elasticsearch/bin/
service/./elasticsearch.java.**status wrapper.script.version=3.5.14
501 9293 9291 16 02:20 ? 00:00:05
/usr/local/jdk1.6.0_34/bin/**java -Delasticsearch-service
-Des.path.home=/usr/local/**elasticsearch -Xss256k -XX:+UseParNewGC
-XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+
**UseCMSInitiatingOccupancyOnly -XX:+*HeapDumpOnOutOfMemoryError
-Djava.awt.headless=true -Xms1024m -Xmx1024m -Djava.library.path=/usr/

*local/elasticsearch/bin/**service/lib -classpath
/usr/local/elasticsearch/bin/service/lib/wrapper.jar:/usr/
local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/
local/elasticsearch/lib/elasticsearch-0.90.2.jar:/usr/
local/elasticsearch/lib/jna-3.3.0.jar:/usr/local/
elasticsearch/lib/jts-1.12.jar:/usr/local/elasticsearch/
lib/log4j-1.2.17.jar:/usr/local/elasticsearch/lib/
lucene-analyzers-common-4.3.1.jar:/usr/local/elasticsearch/
lib/lucene-codecs-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-core-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-grouping-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-highlighter-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-join-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-memory-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-queries-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-queryparser-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-sandbox-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-spatial-4.3.1.jar:/usr/local/elasticsearch/lib/
lucene-suggest-4.3.1.jar:/usr/local/elasticsearch/lib/
spatial4j-0.3.jar:/usr/local/**elasticsearch/lib/sigar/sigar-**1.6.4.jar
-Dwrapper.key=YiWMu02nNu-beU4M -Dwrapper.port=32000
-Dwrapper.jvm.port.min=31000 -Dwrapper.jvm.port.max=31999
-Dwrapper.disable_console_**input=TRUE -Dwrapper.pid=9291
-Dwrapper.version=3.5.14 -Dwrapper.native_library=**wrapper
-Dwrapper.service=TRUE -Dwrapper.cpu.timeout=10 -Dwrapper.jvmid=1
org.tanukisoftware.wrapper.**WrapperSimpleApp
org.elasticsearch.bootstrap.**ElasticSearchF

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearc...@**googlegroups.com.

For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #6