Setting ES_MIN_MEM and ES_MAX_MEM


(Pablo Musa) #1

Hi guys,
I am trying to set -Xmm and -Xms when starting elasticsearch. It should be
very easy clean, however I am using debian and I am running my
elasticsearch by "service" command. I could put it to work editing
.../bin/elasticsearch.in.sh or .../init.d/elasticsearch. But I don't think
this is a good/clean solution. Is there any file where I should put these
settings that will overwrite the default value?

I read the following links but could not find any working solution. (my
installation does not have any elasticsearch.conf).

http://jprante.github.io/2012/11/28/Elasticsearch-Java-Virtual-Machine-settings-explained.html
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-service.html
http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-configuration.html
http://elasticsearch-users.115913.n3.nabble.com/Very-long-GC-td4039479.html


Thanks,
Pablo

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/d8ebe072-fb7b-4ab8-9ecc-9a3246529918%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Mark Walkom) #2

/etc/default/elasticsearch is the one you want.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: markw@campaignmonitor.com
web: www.campaignmonitor.com

On 20 February 2014 03:57, pablitomusa@gmail.com wrote:

Hi guys,
I am trying to set -Xmm and -Xms when starting elasticsearch. It should be
very easy clean, however I am using debian and I am running my
elasticsearch by "service" command. I could put it to work editing .../bin/
elasticsearch.in.sh or .../init.d/elasticsearch. But I don't think this
is a good/clean solution. Is there any file where I should put these
settings that will overwrite the default value?

I read the following links but could not find any working solution. (my
installation does not have any elasticsearch.conf).

http://jprante.github.io/2012/11/28/Elasticsearch-Java-Virtual-Machine-settings-explained.html

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-service.html

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-configuration.html
http://elasticsearch-users.115913.n3.nabble.com/Very-long-GC-td4039479.html
http://jablonskis.org/2013/elasticsearch-and-logstash-tuning/index.html

http://stackoverflow.com/questions/12954136/how-to-set-memory-limits-to-elasticsearch-in-debian

Thanks,
Pablo

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d8ebe072-fb7b-4ab8-9ecc-9a3246529918%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAEM624Y89CSLTXdXZpAOLhdFdqwYQOBwxZW-Pnz2ckz9Hbt0gg%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(Pablo Musa) #3

Great, it worked.
Yesterday I tried adding in this same file the option -Xms=4g in the
ES_JAVA_OPTS but it was not working.
Guess I just had to update the ES_HEAP_SIZE as it was overwriting my
previous option.

Thanks a lot,
Pablo Musa

On Wednesday, February 19, 2014 9:40:24 PM UTC, Mark Walkom wrote:

/etc/default/elasticsearch is the one you want.

Regards,
Mark Walkom

Infrastructure Engineer
Campaign Monitor
email: ma...@campaignmonitor.com <javascript:>
web: www.campaignmonitor.com

On 20 February 2014 03:57, <pabli...@gmail.com <javascript:>> wrote:

Hi guys,
I am trying to set -Xmm and -Xms when starting elasticsearch. It should
be very easy clean, however I am using debian and I am running my
elasticsearch by "service" command. I could put it to work editing .../bin/
elasticsearch.in.sh or .../init.d/elasticsearch. But I don't think this
is a good/clean solution. Is there any file where I should put these
settings that will overwrite the default value?

I read the following links but could not find any working solution. (my
installation does not have any elasticsearch.conf).

http://jprante.github.io/2012/11/28/Elasticsearch-Java-Virtual-Machine-settings-explained.html

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-service.html

http://www.elasticsearch.org/guide/en/elasticsearch/reference/current/setup-configuration.html

http://elasticsearch-users.115913.n3.nabble.com/Very-long-GC-td4039479.html
http://jablonskis.org/2013/elasticsearch-and-logstash-tuning/index.html

http://stackoverflow.com/questions/12954136/how-to-set-memory-limits-to-elasticsearch-in-debian

Thanks,
Pablo

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearc...@googlegroups.com <javascript:>.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/d8ebe072-fb7b-4ab8-9ecc-9a3246529918%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/3e6aa2ba-30c7-42b7-a777-4a90edf33d2a%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #4