Apache Reverse Proxy with Smart Card Login issues


Elastic Stack 6.8
Apache 2.4

In order to do Multi-Factor Authentication I set up an Apache 2.4 Reverse Proxy with SSL. That part works well, it requests the smartcard pin and successfully checks it.

Each and every request takes about 72 seconds.

My thought is that Kibana must be trying to see if Kibana has the user authenticated or not via what Apache just authenticated? I'm not sure, there are zero errors and it just shows that the built_assets directory takes 40-50 seconds to load.

Does anyone have any ideas how I can stop Kibana trying to authenticate against Apache?

Are there any settings in your reverse proxy that disable caching? If so, that would be a reason why Kibana loads so slowly.

I hadn't had Cache enabled. I do so now without any difference. it does seem to be caching as the directory size grows with visits to the site. In the error logs I see a few instances where index.css responded with an uncacheable 304: contradiction: 304 Not Modified, but ETag modified and referred to login?next=%2F

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.