Kibana - Apache proxy reverse


I have used X-pack for ES and kibana and using SSL enabling with apache. The configs are as below

Apache config:

<VirtualHost *:80>
Redirect permanent /
ProxyRequests Off
ProxyVia On

<VirtualHost *:443>

Options FollowSymLinks
AuthType Basic
AuthName "admin"
AuthUserFile /etc/apache2/.htpasswd
Require valid-user

SSLEngine on

SSLCertificateFile certificate path
SSLCertificateKeyFile key path

Kibana.yml: < IP Address of the instance> ""
elasticsearch.url: "http://ipaddress:9200"
server.ssl.cert: certificate path
server.ssl.key: key path

The issue is when i try to login to, the kibana page does not open but when i use then the kibana page opens.

Could you please let me know if iam missing out any configs?

I'm not sure how to configure apache, but it seems like you are actually talking to the kibana server when you access, and not Apache.

@spalge I am using apaphe as reverse proxy to connect to Kibana. I want to connect to Kibana only with the DNS name not with DNS:5601. Is there a way to work around this?

Do you need the apache proxy? You could also just set Kibana to listen on port 80 with the server.port option.

Alternatively, I could help more if you were using nginx, but i don't know how apache works :confused:

@spalger even if I install ngnix I would still have the issue where I need to address kibana with the DNS:5601 right as this has to be ssl enabled.

@spalger could you please let me know how i could browse to kibana without the port no using ngnix?

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.