Api_key does not work behind reverse ssl proxy

This is my first time using ELK stack, and I have found it very useful. I wanted to deploy it behind a reverse ssl proxy using nginx, and have most of the features working fine. However, I am unable to get the xpack.security.authc.api_enabled: true statement to work as I need to enable HTTPS on my ELK stack server (before the reverse proxy). Has anyone ever done this before, or is there a good work around? I am on ELK stack 7.15.
Thank you!

I do not think it is possible to use the API key without HTTPS enabled in Elasticsearch.

Thank you for the reply. That makes sense overall for security, though I hope in the future they add a manual override so you can use it as a reverse proxy.

@gkiesecker This restriction is lifted in the incoming 7.16 release

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.