APM agent not showing transaction logs on Jboss Fuse Pods deployed in Openshift

I have installed APM Java agent "elastic-apm-agent-1.15.0.jar " on the VM where my pod is running. The APM Server
configuration is running fine with Jboss EAP application but when we are using Jboss Fuse application only JVM data is
getting fetched and not the transactional data. APM Server is reachable from this machine.

Please assist where I am doing wrong. We are using Basic version.

Elasticsearch Version: 7.6.0
Kibana Version : 7.6.0
APM Server Version: 1.15.0
JAVA version: openjdk version"1.8.0_191"

Changes in the Server yml used to restart the pod is as below

-Delastic.apm.server_urls= -Delastic.apm.service_name=ESB -Delastic.apm.hostname=ESB_Account
-Delastic.apm.log_level=DEBUG -Delastic.apm.log_file=/home/devops/apm/log/elastic-apm.log
-Delastic.apm.enable_log_correlation=true -javaagent:/home/devops/apm/elastic-apm-agent-1.15.0.jar

Hi and welcome to the forum!

First, try setting the suggested value for Fuse for the boot_delegation_packages config option.

You would get auto-instrumentation tracing depending on which technologies you are using. See this comment and the rest of the contents of this topic. If you don't get what you want out of the box, you may use manual instrumentation instead.

Thank Eyal for your time.

I added boot_delegation

-Delastic.apm.server_urls= -Delastic.apm.service_name=ESB -Delastic.apm.hostname=ESB_Adjustment -Delastic.apm.boot_delegation_packages=org.apache.karaf.jaas.boot,org.apache.karaf.jaas.boot.principal,org.apache.karaf.management.boot,sun.,com.sun.,javax.transaction,javax.transaction.,javax.xml.crypto,javax.xml.crypto.,org.apache.xerces.jaxp.datatype,org.apache.xerces.stax,org.apache.xerces.parsers,org.apache.xerces.jaxp,org.apache.xerces.jaxp.validation,org.apache.xerces.dom,co.elastic.apm.agent.* -javaagent:/home/devops/apm/elastic-apm-agent-1.15.0.jar"

But after adding and doing "oc apply -f xyz.yaml", I even couldn't see that pod in JVM.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.