APM Avg. page load duration distribution by country

If you are asking about a problem you are experiencing, please use the following template, as it will help us help you. If you have a different problem, please delete all of this text :slight_smile:

Kibana version: 7.5.1

Elasticsearch version: 7.5.1

APM Server version: 7.5.1

APM Agent language and version: js-base 4.1.2

Browser version: chrome and firefox

Original install method (e.g. download page, yum, deb, from source, etc.) and version: yum rpm

Fresh install or upgraded from other version? upgraded

Is there anything special in your setup? apm-servers -> logstash -> elasticsearch

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):
I see that recent versions (upgraded recently to 7.5.1) include a worldmap in apm to visualize avg page load duration dist by country.
I have enabled the geoip plugin and can confirm that it works and can see the documents with coordinates and country/region... fields.
However while inspecting in APM, the worldmap is empty. I've tried to find documentation about configuration but couldn't find much.
The only special in my setup is that I have logstash servers in between apm-servers and elasticsearch, but nothing else.

What are the expected fields for the worldmap or configuration in kibana to enable it?
The fields I have with geo information are: geo.location geo.region_iso_code geo.country_iso_code geo.continent_name geo.city_name geo.country_name


Hello Moises, This chart is rendered by data in client.geo.country_iso_code and transaction.duration.us. It sounds like those fields are being populated. Can you look in your browsers developer console and share any errors you see. Also in the network tab of the browser's developer tools, can you look for a request for /api/apm/services/{serviceName}/transaction_groups/avg_duration_by_country. That's the API call to populate this chart, the response might have some more info as to what's going on. - Oliver

Hi Oliver, thank you for your prompt response!

That was the problem, I hadn't the geo fields under client., fixed it quickly by moving them accordingly under client.geo.* in my logstash pipeline

Cheers /moi

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.